1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Password Changing Issue

Discussion in 'Troubleshooting and Problems' started by Ablac, Jan 31, 2014.

  1. Ablac

    Ablac Active Member

    Since my forums arn't active yet were issuing Passwords to our select users and when they try to change there passwords they get an error

    - Error
    Route settings/ could not be found.

    Not sure how to fix this but we've had 4 users say they are not able to change there passwords due to this issue, and we launch in 6 days... and that's a game breaker -_-

    Thanks :)
    Ablac
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Where exactly is that link coming from (settings/)? There is no such route in the default software.
     
  3. Ablac

    Ablac Active Member

    /account/security
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Do you have add-ons installed?
     
  5. Ablac

    Ablac Active Member

    Yes, heres a list of add-ons.

    Installed Add-ons
    1. Admin CP Login Enhanced 1.1.0
    2. AdminCP Firewall 1.3.2
    3. Automatic Warnings by Waindigo 1.0.3a
    4. Email Idle Users by Waindigo 1.0.2b
    5. Enable Debug From Admin Home 1.1a
    6. Force Ignore by Waindigo 1.0.1
    7. Force Register for Guests by xenCODE 1.0.0
    8. GameTracker Viewer 1.0.1
    9. Last Post Avatar by Waindigo 1.1.8c
    10. LiquidPro Simple Forms 2.0.2
    11. Log Out Link by Waindigo 1.0.0
    12. Login As User by Waindigo 1.1.8
    13. LoginUserLocks - Prevent attempts to brute force the login area 1.0.1
    14. MicroSupport 1.0.3 (Disabled)
    15. Minifier 1.0.1
    16. Moderation Queue Information by Waindigo 1.0.0a
    17. Password Strength 1.0.0
    18. Poke by Waindigo 1.0.0
    19. Privacy Groups by Waindigo 1.0.3a
    20. Self Delete by Waindigo 1.0.0
    21. sonnb - Profanity Filter 1.0.4
    22. Tabs by Waindigo 1.0.1c
    23. Template Modification System 1.3.0
    24. TPU: Users can view own warnings 1.0.1
    25. Un-link Banned Users by Waindigo 1.0.0b
    26. Undelete Users by Waindigo 1.0.3b
    27. User Upgrades by Waindigo 1.2.9a
    28. WDB Extra Stats 1.0 (Uninstalling as I posted this)
    29. WebGuruBB.com Admin Notes Addon 1.0.0
    30. Xen Cache 1.0.1
    31. [Nobita] Promote and Demote Member 1.0.2
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    You will need to disable them and confirm it works with them all disabled.

    Then re-enable them one at a time until the error is triggered to determine which one is the cause.
     
  7. Ablac

    Ablac Active Member

    I'm going to attempt this once the Uninstall of Extra Stats 1.0 is finished.

    I am also using the Style UI.X
     
  8. Ablac

    Ablac Active Member

    Interesting error when Disabling all the plugins.

    The following error occurred:
    An exception occurred: Mysqli statement execute error : Deadlock found when trying to get lock; try restarting transaction in /home2/ablac/public_html/library/Zend/Db/Statement/Mysqli.php on line 214

    1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
    2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    3. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 661
    4. Zend_Db_Adapter_Abstract->delete() in XenForo/Model/Template.php at line 1598
    5. XenForo_Model_Template->compileAndInsertParsedTemplate() inXenForo/Deferred/TemplatePartialCompile.php at line 55
    6. XenForo_Deferred_TemplatePartialCompile->execute() in XenForo/Model/Deferred.php at line 252
    7. XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 378
    8. XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 331
    9. XenForo_Model_Deferred->run() in XenForo/ViewRenderer/Abstract.php at line 352
    10. XenForo_ViewRenderer_Abstract::hasManualDeferredToRun() inXenForo/ViewRenderer/Json.php at line 147
    11. XenForo_ViewRenderer_Json::_addDefaultParams() in XenForo/ViewRenderer/Json.phpat line 185
    12. XenForo_ViewRenderer_Json::jsonEncodeForOutput() in XenForo/ViewRenderer/Json.phpat line 37
    13. XenForo_ViewRenderer_Json->renderRedirect() in XenForo/FrontController.php at line593
    14. XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
    15. XenForo_FrontController->run() in /home2/ablac/public_html/admin.php at line 13
     
  9. Ablac

    Ablac Active Member

    Interesting -_- It was either the one I was uninstalling or the problem fixed its self after i enabled/disabled all the addons.
     
  10. Ablac

    Ablac Active Member

    More Interesting fact that i didn't notice but it also stopped me from being able to post by getting rid of the Text Box in the Create a thread section...
     
  11. Brogan

    Brogan XenForo Moderator Staff Member

    Deadlocks can occur, if you tried to disable a lot of add-ons at once, for example.
    Unless it's happening all the time you can ignore that error.
    You may need to do a master rebuild if your templates did not compile correctly.
     

Share This Page