• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

ParseHTML - Permission protected HTML BBCode [Deleted]

infis

Well-known member
#3
This addon is block properly work of event load_class_bb_code: 'XenForo_BbCode_Formatter_Base'.

I write my addon, where I can not load extend class from listener. After disable this addon my listener is working.

Please test this from any over addon with example listener code:
Code:
<?php

class MyAddon_Listener
{
    public static function extend ($class, array &$extend)
    {
        if ($class == 'XenForo_BbCode_Formatter_Base')
        {
            $extend[] = 'MyAddon_BbCode_Formatter_Base';
        }
    }
}
?>
 

ibaker

Well-known member
#4
This mod will not work with the [8wayRun.Com] XenMedio (Media) mod.

When the XenMedio mod automatically creates a thread for any new media entry into it, the PareseHTML mod stops the bbcode from being created properly as a post.

Don't know how to fix this but I need both mods
 

infis

Well-known member
#5
This mod not correctly extend classes. Need rewrite ParseHTML's code with problem, but autor is not it want?
My addon is not working also while ParseHTML is on.
 

Hilmer

Active member
#6
Just a question.

I installed the mod and tried this embed but it does not work:(

<object id="tv2region-videoplayer" width="565" height="320" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000">
<param value="true" name="allowfullscreen"/>
<param value="always" name="allowscriptaccess"/>
<param value="high" name="quality"/>
<param value="true" name="cachebusting"/>
<param value="#000000" name="bgcolor"/>
<param name="movie" value="http://www.tvsyd.dk/modules/tv2region/video/flowplayer.commercial-3.2.5.swf" />
<param value="config=http://www.tvsyd.dk/flowplayer/52393" name="flashvars"/>
<embed src="http://www.tvsyd.dk/modules/tv2region/video/flowplayer.commercial-3.2.5.swf" type="application/x-shockwave-flash" width="565" height="320" allowfullscreen="true" allowscriptaccess="always" cachebusting="true" flashvars="config=http://www.tvsyd.dk/flowplayer/52393" bgcolor="#000000" quality="true">
<a href="" target="_blank"></a>
</embed>
</object>

maybe you can help?
 

ibaker

Well-known member
#9
Dark, I also think this is a great mod...my site would be very basic without it...I just wish you and Jaxel could get together and work out how to fix his Medio mod to work with your mod...many users want to use both of your mods but when both are installed his mod breaks with auto creating an entry in the forums when a video is added...something to do with the bbcode setup with both of your mods working together.

PLEASE see if you can help resolve this as your mod is greatly appreciated
 

DRE

Well-known member
#10
Dark, I also think this is a great mod...my site would be very basic without it...I just wish you and Jaxel could get together and work out how to fix his Medio mod to work with your mod...many users want to use both of your mods but when both are installed his mod breaks with auto creating an entry in the forums when a video is added...something to do with the bbcode setup with both of your mods working together.

PLEASE see if you can help resolve this as your mod is greatly appreciated
Are you saying that when ParseHTML is installed, embedding videos with jaxel's medio mod doesn't work?
 

ibaker

Well-known member
#11
If you have ParseHTML and Jaxel's Medio mod installed and you select to automatically create a new forum thread when a user adds a video to the Medio mod, the post that is created is just plain bbcode and not a proper post. It has been mentioned many times and I have asked that the two of them talk to each other to resolve it for everyone but with no luck.

See here:
http://xenforo.com/community/threads/8wayrun-com-xenmedio-media.26849/page-4#post-339522
 

cclaerhout

Well-known member
#13
Could you please correct this:
Code:
"class Dark_ParseHTML_BbCode_Formatter_Ritsu extends XenForo_BbCode_Formatter_Base"
to
Code:
"class Dark_ParseHTML_BbCode_Formatter_Ritsu extends XFCP_Dark_ParseHTML_BbCode_Formatter_Ritsu"
it will allow other developper to listen the bbcode class to without any problems and without spending two hours to understand why their hack doesn't work ^^
Thank you


Edit: oups i've tried above solution and it breaks your addon. I don't know why. But your addon prevent others to access XenForo_BbCode_Formatter_Base


Edit2: oups i didn't see others had this problem too :D
 

ibaker

Well-known member
#17
Hi Dark
There are a lot of us that use your great mod, in fact depend so much on it, but also use Jaxel's Media mod however there is a clash between yours and his. Please see post 11 above.

Is there any way, any way at all that this can be resolved...PLEASE!
 

Arkshine

Active member
#18
Hi,

There is also a clash with "Merge Double User Post" addon. When I enable "ParseHTML", the [MERGETIME="xxxxx"][/MERGETIME] inside post content is not parsed anymore.
I hope it can be fixed, assuming it's an issue from this addon.

Thanks.
 

DRE

Well-known member
#20
Could you please correct this:
Code:
"class Dark_ParseHTML_BbCode_Formatter_Ritsu extends XenForo_BbCode_Formatter_Base"
to
Code:
"class Dark_ParseHTML_BbCode_Formatter_Ritsu extends XFCP_Dark_ParseHTML_BbCode_Formatter_Ritsu"
it will allow other developper to listen the bbcode class to without any problems and without spending two hours to understand why their hack doesn't work ^^
Thank you


Edit: oups i've tried above solution and it breaks your addon. I don't know why. But your addon prevent others to access XenForo_BbCode_Formatter_Base


Edit2: oups i didn't see others had this problem too :D
Where do we change this at?