1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

OS/Browser Display [Paid] 1.0.13

Shows user's OS/Browser in extra user info.

  1. Snog

    Snog Well-Known Member

    Snog submitted a new resource:

    OS/Browser Display - Shows user's OS/Browser in extra user info.

    Read more about this resource...
    Last edited: Jul 30, 2015
  2. DirtRider

    DirtRider Guest

    I find this mod so great and especially when trying to resolve issues members may have on my forum.
    TsinJu likes this.
  3. DRE

    DRE Well-Known Member

    @EliasAlucard wants to know if you are releasing this under the GPL v3 license.
  4. CFodder

    CFodder Well-Known Member

    Do users have the option to turn this off in their privacy settings?
  5. Snog

    Snog Well-Known Member

    Absoulutely not.

    This does NOT contain ANY GPL code.
    Last edited: Feb 23, 2014
  6. Snog

    Snog Well-Known Member

    No they don't.

    The information shown is sent out every time someone visits a web page. It is recorded in the logs of every server they visit.

    If this is really a concern, you can choose to display it only to the usergroups of your choice.
    Last edited: Feb 23, 2014
  7. DirtRider

    DirtRider Guest

    All the time I have been using this type of mod on different forum software I have never had any members request that their information is not shown. I cannot even think of any reason why you would not want this information shown.
  8. mcatze

    mcatze Well-Known Member

    Cause the privacy .. ;)
  9. DirtRider

    DirtRider Guest

    I think some people place too much on privacy when going online and if they so worried about that maybe they should not do so. I can extract more private information about someone than just knowing what OS and Browser they may or may not be using. However as stated you able to only show this to selected groups if that is an issue on your forum. Also remember that these groups would most likely have IP viewing capabilities as well.
  10. Snog

    Snog Well-Known Member

    To my knowledge, displaying the OS and Browser someone is using does not fall under any privacy laws of any country. Displaying that information does not disclose any personally identifiable information and is not unique to an individual. You will find that many users are using the same OS and Browser. There are also no cookies involved so the cookie law also doesn't apply.

    However, I will put the option on the wish list for this add-on.
    DirtRider likes this.
  11. CFodder

    CFodder Well-Known Member

    Was only wondering, don't have any privacy concerns with it myself.

    Yep, saw that feature :).

    Only asked because some people get a bit uptight when ANY information is passed back that they can't control ... generally they're the ones with tinfoil hats ;).

    Completely agree, anyone really worried about privacy shouldn't be on the net!

    As I first said, only wondered - I don't mind if it is there or not.
  12. DirtRider

    DirtRider Guest

    At times I also find with all the technology available members will jump between devices during the day so they would have posted using multiple combinations. Later they will report they had an issue posting x post and with this it is easy to see the combination used and fault find it using the same combination. We sure need all the tools we can have at hand at times like these :D
    CFodder likes this.
  13. CFodder

    CFodder Well-Known Member

    Not wrong, luckily most of our members aren't up with the play and struggle to turn a PC on let alone try and use a mobile device :p.
  14. DirtRider

    DirtRider Guest

    If anyone has to watch my combination in posting it would be a nightmare as I can go from Windows any version using a combination of browsers to different mobile device also using different browsers :LOL:
  15. BamBam

    BamBam Active Member

    cURL is installed, but i have only this Error Massge during Install: "An unexpected error occurred. Please try again later." :oops:
  16. Snog

    Snog Well-Known Member

    Most likely it is because PHP is running as a different user than your FTP account.

    Delete everything in the library/Snog folder (just the OSBrowser folder if you have more than one of my add-ons) and change permissions of the Snog folder to 777.

    Also be sure the data/osbrowser folder is also set to 777.
  17. BamBam

    BamBam Active Member

    osbrowser Folder and all Files in there has 777, also the Snog Folder has 777. I cant delete this Folders anymore:


    550 DataWriter: Permission denied. I really dont know whats wrong. Anyway, thx for you help Snog.
  18. Snog

    Snog Well-Known Member

    Are you running Nginx by some chance?

    The inability to remove the folders is a sure sign that Nginx is running PHP either as the 'nobody' user or another odd user and is forbidding access to the files created by the installer. Someone else ran across this problem the other day. They changed the user that PHP runs as to the same one as the FTP account and all worked properly for them.

    The user that runs PHP should be the same one that would own the web root directory and would be used for FTP/SSH upload AND would run php
    Last edited: May 26, 2014
  19. BamBam

    BamBam Active Member

    On my small managed VPS, there is Apache - no Nginx. I dont know how to change Users. There a some Server Errors like this: ErrorException: unlink(osb_install.php): Permission denied - library/Snog/OSBrowser/Install.php:40

    But i cant delete this Folder, and i cant change Permission anymore...your Addon is really complicated. :cry:
  20. Snog

    Snog Well-Known Member

    You're the first person to have this problem that is running Apache.

    That error did help me locate what could be the problem. And since everything else seems to be getting installed (per your screenshot of the folder), it should be fixed now.

    Try installing again.

    So far as not being able to delete the files, I'm sure that has to do with your FTP user permissions. Try deleting them from your control panel.
    BamBam likes this.

Share This Page