XF 2.2 Original Thread Posts Doubling Up, Comments Disappearing

In the past 4-5 days, we've encountered a strange set of bugs.

First, some of our thread posts are doubled up. The original post, that is. And, these posts have the same ID, so, deleting the double, ends up deleting the entire thread.

Second, some of the comments have been disappearing (without mod/admin/user deletion). These comments still show up in the logs, but cannot seem to be restored to the actual threas.

As far as we know, we didn't do somethin 4-5 days ago to trigger these bugs.

Could anyone please help us with this?

(We've checked on the server end, given a comment by djbaxter on a similar thread, it appears this is not the issue here. No server errors. Server resources are okay).

(We've also done a basic check of the SQL databases. No errors.)
 
Last edited:

Brogan

XenForo moderator
Staff member
If there is only a single entry in the DB for the duplicate threads then it sounds like a style issue, or possibly a third party add-on involved.

Disabling all add-ons and reverting to a default style will confirm that.
 
Thank you @Brogan , we'll try that next if the problem continues.

We might have solved it.

The main forum admin did a cache re-build a little while ago. He thinks that may have fixed the problem, but, also produced some artifacts (the ones described above). To try to fix said artifacts, he kept trying to re-build the cache (which might have been introducing more artifacts, thus making it worse).

He stopped trying to fix it yesterday, if no new 'artifacts' show up today or beyond, we'll probably assume that was the problem.
 
Last edited:

Brogan

XenForo moderator
Staff member
Rebuilding the cache shouldn't result in issues such as that.

I suspect there may be something external involved if that is the case.
 
Rebuilding the cache shouldn't results in issues such as that.
I think the cache thing is the only thing we've done recently, leading up to the issues.

Granted, could be an issue which took time to manifest, or was introduced in some other manner.

Forgot to mention above.
We checked the server speeds and storage, all good there.

We checked for viruses, all good there.

We tried with a default theme, as you suggested, all good there.

The only thing we haven't tried yet, that we know to try, is disabling the add-ons, as you've suggested above. We hadn't installed any new add-ons recently, so I'm sure why the issue would have showed up now vs. earlier (i.e., closer to when we installed add-ons).
I suspect there may be something external involved if that is the case.
External. How so?

Edit (extra detail):
We are using this add-on, which we suspect might be the add-on responsible for the issues (if it is indeed an add-on related issue).

That add-on, for chained/treed replies, has its own cache structure. This is part of what we re-built.

cache rebuild.png
 
Last edited:
Top