• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 OpenGraph Warnings

Jake B.

Well-known member
#1
Not extremely familiar with the OpenGraph standard, but we're getting the following warnings when testing it using Facebook's debugger:

  • Object Missing a Required Value
    Object at URL 'https://www.southeasttraders.com/' of type 'website' is invalid because a required property 'og:title' of type 'string' was not provided.
  • Inferred Property
    The 'og:image' property should be explicitly provided, even if a value can be inferred from other tags.
The opengraph tags being rendered on the page are:

Code:
<meta property="og:site_name" content="Southeast Traders" />
<meta property="og:image" content="https://www.southeasttraders.com/styles/common/logo.og.png" />
<meta property="og:type" content="website" />
<meta property="og:url" content="https://www.southeasttraders.com/" />
<meta property="og:title" content="Southeast Traders" />
<meta property="og:description" content="Southeast&#039;s best outdoor trading community. Firearms and outdoors related discussion with free and very active classifieds section! Forums for guns, hunting, fishing, class iii weapons, and much more! Georgia, Florida, Tennessee, Alabama, Kentucky, Arkansas, Virginia, Mississippi, Louisiana, Texas, North Carolina and South Carolina." />
The tags are being generated by XenForo, and we haven't touched the open_graph_meta template at all, so I'm not sure why it'd be throwing errors as I've tested it with https://www.xenforo.com/community and it behaves fine, and obviously the tags are nearly identical