1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 One discontnued add-in stopped reading its own CSS today. Not sure what broke.. [Solved]

Discussion in 'Styling and Customization Questions' started by Phases, Dec 1, 2013.

  1. Phases

    Phases Active Member

    For some reason the CSS templates that are being called aren't working for my albums product all the sudden. I've done a lot of work today and can't pinpoint it, but I have realized they aren't providing the styling to any of the classes being called.

    I can clearly see in the source that the css file isn't being called in, but the syntax is correct and the file shows in the grouping when looking at the template. And I didn't change anything in there today, just all over outside of it.

    My site is http://www.ballisticallyspeaking.com

    Better explanation a few posts down. If anyone can help, please do - I'm stumped and this is sorta a major deal for me and holding me way back. :(

    Attached Files:

    • xfr.png
      File size:
      21.5 KB
    Last edited: Dec 1, 2013
  2. Shelley

    Shelley Well-Known Member

    As far as I am aware it means it's a template you've edited.
  3. Phases

    Phases Active Member

    Nah, those are all red, the whole tab. And, SOME of those have red dots and most don't. In this case, just the font is a different color with a red dot. Since I'm having all this trouble with it apparently not styling its classes, I can only hope this is leading to the problem.
  4. Phases

    Phases Active Member

    Ah the red dot means you've edited but not yet saved - but I still need to know what the darker text on a white tab means.
    Shelley likes this.
  5. Shelley

    Shelley Well-Known Member

    The black text? that would mean a template hasn't been edited in anyway and is still a xf default untouched template. Sorry If i misunderstood what your asking.
  6. Phases

    Phases Active Member

    No, its a dark red text on a white background. I've never seen it before. I made a quick edit and saved it, so I could then revert it, and now its back to black text on white tab.
  7. Shelley

    Shelley Well-Known Member

    oh I see. I'm not entirely sure. Could that be a custom 3rd party template that either still needs saved or has been saved? I'm guessing.
  8. Phases

    Phases Active Member

    It is back to red again. Red text, red dot, white tab - templates I've not edited. All in the product that isn't providing CSS right.
  9. Steve F

    Steve F Well-Known Member

    Red dot - changes not saved
    Red Tab - A template that has been edited from default

    There is version history for the templates, so if the tab is red it should show a history for edits.

    What do you mean isn't providing CSS right?
  10. Phases

    Phases Active Member

    I don't know, I have no idea what is going on. I'm about to cry. I've worked on this thing non stop for 2 weeks and now things are falling apart in front of me and I don't know what I did to prompt it.

    1. For one add-in (gallery) all it's css files are there, the templates all look the same comparing to default style, and when I inspect element I see that class="whatever" is all being used right, but when I look on the right at the applied stylings NONE of the add-in specific stuff is there. Yet, on another browser with another theme it all is.
    2. My join now banner is, as far as I can tell, coded right to drop the login bar down on click, but instead it is going to the register page. The one person who tried to help me with it is seeing totally whack stuff in the source, some of which I see with "inspect" with chrome. <a>'s all over the place, for example.

    I feel like I'm in the twilight zone.

    I don't know what to say anymore. I've put so much energy into this over two weeks, I was about to be finished, and now this. And I'm not 100% sure when the root of the problem, whatever it is, started.


    It's the gallery you see at the bottom of the forum index. There is one image in it but it's supposed to be styled different, the numbers under the image are supposed to have little images, it's trying to call various things in .css files, adn the files are there, but nothing is happening, and I didn't tell anything to stop requiring the css.. I see the includes in the templates.

    If anyone can think of anything that would be interferring with stuff, PLEASE let me know..
    Last edited: Dec 1, 2013
  11. Jeremy

    Jeremy XenForo Moderator Staff Member

    To answer your original question, what Shelley said is correct.

    Red = Edited from default
    Red Dot = not saved
    Black = not edited from default.

    White background is just the template you are currently editing (shown in the text area).
  12. Phases

    Phases Active Member

    If you inspect with chrome, the random images at hte bottom of forum index, you'll see it is trying to call all sorts of things like "thumbox", "ImageboxOpener" , "firstimage", "thumbnailholder", all these things.

    Yet on the right, in the matched css section, none of that shows. It all does on a diff style as it should, and it works fine.

    These are all in css templates that are in fine and unedited shape. The other template files for this plugin are in tact to. I've even gone back and reverted the one I did edit. Yet, this problem remains.

    I've uninstalled and reinstalled.. I've gone down every single template and css file and reviewed histories. I went down every single styple property to look for missing ; or something..

    I'm at a real loss here, they were great until some time today.

    have included ALL css files at the top of page_container as a test - no change. What the heck..
    Last edited: Dec 1, 2013
  13. Phases

    Phases Active Member

    I'm at my wits end. If anyone has any ideas at all please let me know. The template to load in those images is loading fine, yet the CSS it is calling in that very file just doesn't come. But I'm looking right at it. Syntax, name, it's all right..

    Ooh, it looks like it's also failing to read class "categoryStrip" which isn't from the plugin..

    It's like CSS stops working once it hits the bottom of my node list and pics right back up after the random image box.

    I've tried disabling all other plugins, copying over default templates for some of the major ones (navigation, page container, etc), I just can't pinpoint it.
    Last edited: Dec 1, 2013
  14. Steve F

    Steve F Well-Known Member

    Does everything work on the default style? Not sure if you said that directly or not but I would start there. Without knowing what has been edited it is really hard to say other than your missing a closing ' } ' somewhere or something.
  15. Phases

    Phases Active Member

    Yeah everything does in the default style, and I've gone down everything wherewhere to try to find a missing } or ;... that's gotta be it..

    Is there any tool that would point it out? I tried css verifiers..
  16. Steve F

    Steve F Well-Known Member

    Well, you could reimport the style your using fresh and start comparing templates. Are you using a decent text editor? Notepad++ will help you with syntax highlighting, just choose the language of the code you are working on.
    Phases likes this.
  17. Phases

    Phases Active Member

    Good God I finally found it! I'm tired. It's been a long night, and I needed that reminder to use Geany to check for open/close's .

    In the sidebar CSS for this style I found this:
    body .sidebar .secondaryContent { 
    background-color: #fbf7ed;    
    border-bottom: 0px;
    Do you see what I did there?

    I feel so dumb. This has put me so far behind.

    Thanks a ton! Now back onto my other posts here to finish up my last couple things before launching.

Share This Page