XF 2.0 Not Getting Two-Step Verification Mails

Car_Freak

Member
Hello,

From last few days I’m noticing that I’m not getting Two-Step Verification Code E-mails upon logging in.

Until a couple of days back though, when I logged-in using Backup Code, I did get a mail that a Backup Code was used.

However, now I’m not getting that mail either. My server support team seems clueless.

It’s quite urgent. Can someone help figure out what’s the matter?

PS: No changes were made to forum settings or server settings in the recent past (except automatic server updates if any).

Thanks
 
Solution
My host is advising me to use a 3rd-Party to send bulk e-mails because according to them it isn’t legit to send them through hosting server.
You host is full of bullhockey. The issue is that there email server has a poor reputation and is getting marked as spam (possibly due to other users if shared hosting).
Have you set up DKIM and SPF in your DNS?
These authentication methods are set up at your domain provider. If you use a domain hosting service or an email provider, use the provider's instructions for setting up authentication. Set up authentication for each of your sending domains.

To minimize the chance that your messages are marked as spam, set up these...

Car_Freak

Member
I tested with a different user account which has associated mail address of my own domain (test@mydomain.com).

This time I received the Two-Step verification Code. Pretty strange.

However, when I login to my own user account which has a G-Mail address associated, I’m not getting the codes.

I’ve already waited for minutes to receive the code, checked Trash & Spam folders as well as checked Blocked senders list. No luck.

Since I’m getting codes on a different mail address, hosting team says there’s no problem from the server-side. Though they've asked:

Is XenForo using your server to send Two-Step codes, or is it using your domain, or do they have their mail server to send a 2FA code?

I'd appreciate some support.

Thanks.
 

Brogan

XenForo moderator
Staff member
If emails are being received by at least one account then that confirms the XF software and email sending functionality is working.

The host's question doesn't really make any sense - all emails sent by XF use the same method configured in the ACP.

They can check the server mail log to confirm emails are being sent by XF, and received by the server.
 

Car_Freak

Member
Hi @Brogan. Thanks for the response.

Today I received a mail titled “Mail delivery failed: returning message to sender” from "mailer-daemon@host.mydomain.com".

Note: Here mydomain.com is just an alternate name to my actual domain name.

The content were as follows:
This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

xxxxxxx@gmail.com
host gmail-smtp-in.l.google.com [173.194.XXX.XX]
SMTP error from remote mail server after end of data:
550-5.7.26 This message does not have authentication information or fails to
550-5.7.26 pass authentication checks. To best protect our users from spam, the
550-5.7.26 message has been blocked. Please visit
550-5.7.26 https://support.google.com/mail/answer/81126#authentication for more
550 5.7.26 information. w7si6637422qkf.334 - gsmtp
Below this text were the actual content of Xenforo Login Verification code (which I myself requested).

My host is advising me to use a 3rd-Party to send bulk e-mails because according to them it isn’t legit to send them through hosting server.

This is strange. I’ve been hosting forums for the past 12 Years but never had this kind of problem.

Can you advise if there’s any setting in XenForo to prevent these as “bulk” mails?

Perhaps by limiting quantity of mails sent per batch as well as delaying the intervals they’re sent?

Looking forward to a response soon. Thanks.
 

Tracy Perry

Well-known member
My host is advising me to use a 3rd-Party to send bulk e-mails because according to them it isn’t legit to send them through hosting server.
You host is full of bullhockey. The issue is that there email server has a poor reputation and is getting marked as spam (possibly due to other users if shared hosting).
Have you set up DKIM and SPF in your DNS?
These authentication methods are set up at your domain provider. If you use a domain hosting service or an email provider, use the provider's instructions for setting up authentication. Set up authentication for each of your sending domains.

To minimize the chance that your messages are marked as spam, set up these authentication methods:

  • Publish an SPF record for your domain. SPF prevents spammers from sending unauthorized messages that appear to be from your domain.
  • Turn on DKIM signing for your messages. Receiving servers use DKIM to verify that the domain owner actually sent the message. Important: Gmail requires a DKIM key of 1024 bits or longer.
  • Publish a DMARC record for your domain. DMARC helps senders protect their domain against email spoofing.
For SPF and DKIM to authenticate a message, the message From: header must match the sending domain. Messages must pass either the SPF or the DKIM check to be authenticated.
 
Solution
Top