• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Node-/Subforum in different Color

vFranky

Active member
#1
Hello,

can I set the title of a node/subforum to a different color? We use this to mark moderative, internal forums.

Kind regards,
Frank
 

Brogan

XenForo moderator
Staff member
#2
Add to EXTRA.css:
Code:
.nodeList .node_1 .nodeTitle a
{
  color: orange;
}
Changed the 1 to the node ID.

If you want to make multiple forums the same colour, do it like so:
Code:
.nodeList .node_1 .nodeTitle a,
.nodeList .node_2 .nodeTitle a,
.nodeList .node_3 .nodeTitle a
{
    color: orange;
}
 

vFranky

Active member
#4
I used your CSS code. But now there is no alternate color if new content in a node exist. Can I define an alternate color too?
 

Brogan

XenForo moderator
Staff member
#5
Use this for unread and read:
Code:
.nodeList .node_1 .unread .nodeTitle a
{
    color: green;
}

.nodeList .node_1 .nodeTitle a
{
    color: orange;
}
 

vFranky

Active member
#6
Thank you, I made this css code, but unread does not work. Any idea?

.nodeList .node_121 .unread .nodeTitle a,
.nodeList .node_125 .unread .nodeTitle a,
.nodeList .node_128 .unread .nodeTitle a,
.nodeList .node_133 .unread .nodeTitle a,
.nodeList .node_134 .unread .nodeTitle a,
.nodeList .node_135 .unread .nodeTitle a,
.nodeList .node_136 .unread .nodeTitle a,
.nodeList .node_144 .unread .nodeTitle a,
.nodeList .node_153 .unread .nodeTitle a,
.nodeList .node_154 .unread .nodeTitle a,
.nodeList .node_163 .unread .nodeTitle a,
.nodeList .node_167 .unread .nodeTitle a,
.nodeList .node_178 .unread .nodeTitle a,
.nodeList .node_185 .unread .nodeTitle a,
.nodeList .node_193 .unread .nodeTitle a,
.nodeList .node_198 .unread .nodeTitle a,
.nodeList .node_199 .unread .nodeTitle a
{
color: #660033;
}

.nodeList .node_121 .nodeTitle a,
.nodeList .node_125 .nodeTitle a,
.nodeList .node_128 .nodeTitle a,
.nodeList .node_133 .nodeTitle a,
.nodeList .node_134 .nodeTitle a,
.nodeList .node_135 .nodeTitle a,
.nodeList .node_136 .nodeTitle a,
.nodeList .node_144 .nodeTitle a,
.nodeList .node_153 .nodeTitle a,
.nodeList .node_154 .nodeTitle a,
.nodeList .node_163 .nodeTitle a,
.nodeList .node_167 .nodeTitle a,
.nodeList .node_178 .nodeTitle a,
.nodeList .node_185 .nodeTitle a,
.nodeList .node_193 .nodeTitle a,
.nodeList .node_198 .nodeTitle a,
.nodeList .node_199 .nodeTitle a
{
color: #003300;
}
 

Brogan

XenForo moderator
Staff member
#9
You will need to contact the style designer.
I wouldn't know why the CSS is being ignored - perhaps they use different classes?
 

Martok

Well-known member
#12
Strange, it works not in my case. :(
I even used your code, just changed the node IDs.

Are you sure you have the node IDs correct?
Are you putting it in EXTRA.css for your child style that you are using (and not EXTRA.css for any other style)?
Are you using any other add-ons or have you added any other code that could affect node titles?
 

vFranky

Active member
#13
Martok, it seems everything is correct. But I don't know if there are perhaps addons which affect CSS. The color setting works, but the unread portion not.

It is not so important. If it doesn't work, it is postponed.
 

Martok

Well-known member
#14
Martok, it seems everything is correct. But I don't know if there are perhaps addons which affect CSS. The color setting works, but the unread portion not.

It is not so important. If it doesn't work, it is postponed.
I checked unread too and that did work.

Can you post a link to your site so I can have a look?
 

vFranky

Active member
#15
Sorry, not possible because it is interal (moderator area). I will configure it externally for testing purpose and will inform you, when it is completed. Thank you in advance for your support.