XF 2.2 New install - went well until I tried to use it

I'm sure this is a simple solution (a permission perhaps?) but on a fresh install I'm getting the following rather than what I would expect to see:
1612212205807.png

I'm helping my 15 year old son set this up and I'm stuck.

Can anyone point me in the right direction?

Thanks,

-John
 
I'm seeing 500 errors for the CSS.

Ask your host to check the server error log to determine the cause.

You should also ask them to install a free SSL certificate so the site is secure and available over https.
 
As usual Brogan, their reply is out of my pay range. Here is what they had to say:

_________________________________________________________________________________________________________________________________
Greetings,

In the cPanel account for nwircforum.com under Metrics > Errors, there are a few notices being recorded, however those don't appear to be the reason the site is posting weird.
---
2021-02-01 14:24:48.337617 [NOTICE] [28772] [/home/ice/public_html/.htaccess:9] Unsupported ErrorDocument URL: default, must start with '/' or 'http'.
2021-02-01 14:24:48.337596 [NOTICE] [28772] [/home/ice/public_html/.htaccess:8] Unsupported ErrorDocument URL: default, must start with '/' or 'http'.
---

We did enable debugging for the site inside of /src/config.php and an error is now showing when visiting http://nwircforum.com/css.php?css=p...32&k=4da7fed7a866e75f300abfc6772e79f8485cfdfe.
---
An exception occurred: [Error] Class 'Less_Tree_Mixin_Definition' not found in src/vendor/oyejorge/less.php/lib/Less/Parser.php on line 2736

1. Less_Parser->NewObj5() in src/vendor/oyejorge/less.php/lib/Less/Parser.php at line 1727
2. Less_Parser->parseMixinDefinition() in src/vendor/oyejorge/less.php/lib/Less/Parser.php at line 858
3. Less_Parser->MatchFuncs() in src/vendor/oyejorge/less.php/lib/Less/Parser.php at line 1009
4. Less_Parser->parsePrimary() in src/vendor/oyejorge/less.php/lib/Less/Parser.php at line 674
5. Less_Parser->GetRules() in src/vendor/oyejorge/less.php/lib/Less/Parser.php at line 621
6. Less_Parser->_parse() in src/vendor/oyejorge/less.php/lib/Less/Parser.php at line 449
7. Less_Parser->parse() in src/XF/CssRenderer.php at line 412
8. XF\CssRenderer->renderToCss() in src/XF/CssRenderer.php at line 350
9. XF\CssRenderer->renderTemplate() in src/XF/CssRenderer.php at line 258
10. XF\CssRenderer->renderTemplates() in src/XF/CssRenderer.php at line 116
11. XF\CssRenderer->render() in src/XF/CssWriter.php at line 53
12. XF\CssWriter->run() in css.php at line 30
---

We recommend double checking the installation procedure to make sure everything was done properly. This looks like a PHP class error that related to the logic of the site or perhaps missing files/custom plugins/themes.

As for the SSL, AutoSSL has been run for the site and there is now a SSL certificate on the domain that does not expire till May 2, 2021. This was done in the cPanel account under Security > SSL/TLS Status > Run AutoSSL.
---
---
_________________________________________________________________________________________________________________________________

I look forward to any suggestions you may have (including a fresh install if necessary). I have another Xenforo running on this hosting account quite well so I don't think it's the server/host.

Thanks,

-John
 
I am able to log into the ACP. It's a little wonky but I ran the file-check and received the following (I didn't modify any files, strictly FTP'd them and ran the /install.pph):

File health check results​

Re-run check
Check completed on 4,920 files. The files listed below have contents different from those originally downloaded.

If you have edited these files yourself, you may ignore this message, otherwise you should investigate further as this may be evidence of corrupted or altered files.
XenForo
src/vendor/oyejorge/less.php/lib/Less/Tree/Mixin/Definition.php Missing
 
Back
Top Bottom