1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Need some help here, mysql re-install caused this error

Discussion in 'Troubleshooting and Problems' started by mauzao9, May 1, 2016.

  1. mauzao9

    mauzao9 Well-Known Member

    On parts of the website, this is the server error:

    An exception occurred: Call to undefined function utf8_decode() in /var/www/html/library/Lgpl/utf8.php on line 96
    utf8_strlen() in XenForo/Helper/String.php at line 193
    XenForo_Helper_String::wholeWordTrim() in XenForo/Template/Helper/Core.php at line 1387
    XenForo_Template_Helper_Core::string() in XenForo/Template/Abstract.php(265) : eval()'d code at line 259
    eval() in XenForo/Template/Abstract.php at line 265
    XenForo_Template_Abstract->_renderInternal() in XenForo/Template/Abstract.php at line 191
    XenForo_Template_Abstract->render() in XenForo/Template/Public.php at line 110
    XenForo_Template_Public->render() in XenForo/ViewRenderer/HtmlPublic.php at line 140
    XenForo_ViewRenderer_HtmlPublic->renderContainer() in XenForo/FrontController.php at line 637
    XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
    XenForo_FrontController->run() in /var/www/html/index.php at line 13
    I remember i had to deal with this before, but i need guidance on this utf8 thing again,
  2. Brogan

    Brogan XenForo Moderator Staff Member

    mauzao9 likes this.
  3. mauzao9

    mauzao9 Well-Known Member

    Yup, using php7 there seems to be stuff that are not by default there that should be and that fixes it.
  4. Tracy Perry

    Tracy Perry Well-Known Member

    Depends on what you consider "default". It all depends on the OS, whether you do a self compile, whether that module has been ported upwards to support PHP 7, whether you are using a panel and a few other factors.
  5. rv65

    rv65 Active Member

    to fix that issue at least in Ubuntu install php-xml.

Share This Page