• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
  • This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

NavManager

#41
Based on your last post, this works now with Flexile, and thank you, I appreciate it. One thing seems to be off here, (maybe I'm missing something)
Using the Flexile theme, when you go to a 'tab', it doesn't actually stay on that tab, it will take you back to the home tab. To see what I'm talking about (not trying to self promote), go to the project site in my sig and look @ the band tab. Instead of staying on the band tab (and having subpages come up as links), it throws the navigation menu back to 'forums', or the first link, whatever that may be.
 

Astrum

Active member
#42
This is due to the way XenForo handles which tab is selected (by the majorSection in a route prefix). This isn't inherit to this plug-in, although I would like to research a possible way to side step this issue.

For now please check out this plug-in. I haven't used it personally, but this should do it for you.
 

jor956

Active member
#43
Doesn't seem to work well with Xenporta, it doubles on the User, Inbox, Alerts and Log Out buttons; and also adds an extra home button on.. Could you please fix this?
Thanks.
Screen shot 2011-05-02 at 3.29.58 PM.png
 

Astrum

Active member
#45
Well there's two parts to this actually. The first part is Flexile which moved the account links to the moderation bar rather than keeping it in the navigation bar. To fix this please see this post. If you already did this and it's still not working please give me a link to your website (either here or in a PM) and I'll look at what's going on. For the next release I'm planning on making this easier, though not necessarily fool proof. Hopefully I have time to work on it soon.

For the second part it does have to do with XenPorta (the second Home tab). I'll have to look into this more later however.
 

jor956

Active member
#46
Well there's two parts to this actually. The first part is Flexile which moved the account links to the moderation bar rather than keeping it in the navigation bar. To fix this please see this post. If you already did this and it's still not working please give me a link to your website (either here or in a PM) and I'll look at what's going on. For the next release I'm planning on making this easier, though not necessarily fool proof. Hopefully I have time to work on it soon.

For the second part it does have to do with XenPorta (the second Home tab). I'll have to look into this more later however.
Thank you for your assistance, it is greatly appreciated :D
 

jor956

Active member
#47
Well there's two parts to this actually. The first part is Flexile which moved the account links to the moderation bar rather than keeping it in the navigation bar. To fix this please see this post. If you already did this and it's still not working please give me a link to your website (either here or in a PM) and I'll look at what's going on. For the next release I'm planning on making this easier, though not necessarily fool proof. Hopefully I have time to work on it soon.

For the second part it does have to do with XenPorta (the second Home tab). I'll have to look into this more later however.
I found a temporary fix for the second tab, I just turned of navigation tab in Xenporta, although the tab does not show as selected when activated.. Is that a problem with Navmanager? Is it being worked on?
 

Astrum

Active member
#48
This is due to how XenForo deals with which tab is selected, namely comparing the tab key with the majorSection from the route prefix.

In this particular instance there are two things you can do to get this to work. The first, and easiest, is to edit the Home navigation node in the Navigation Manager area of AdminCP (AdminCP->Applications->Display Navigation Nodes->Home). Change the Public Navigation Node Id to "portal" rather than "home" and save it, the rest of the fields don't matter. Second, enable the XenPorta option "Show Navigation Tab?" in the AdminCP->Options->[8wayRun.Com] XenPorta (Portal) options area. Since this add-on runs before XenPorta when adding custom tabs, XenPorta will override the Home tab from this add-on when it runs and it should work fine. The down side to this is you can't customize it in any way and it's a bit kludgy, but it does work and it's easy.

The second method, one which is quite a bit more involved, is to recreate the XenPorta navigation nodes in this add-on. I'm actually not going to detail how to do this method unless you specifically want to use it as it requires a PHP callback method. For now I suggest you use the first method until the next version of this add-on is released.
 

PoLiZe

Well-known member
#49
I need put this url on the "link"

{xen:link 'misc/style', '', 'style_id=7', '_xfToken={$visitor.csrf_token_page}

How i can put that?
 

yavuz

Well-known member
#50
I'm following this thread for further developement and agree with that this should be in the core. Hope it gets updated further.
 

Astrum

Active member
#51
This is the greatest mod to any site Administrator and the ability to manage the navbar like this should be a part of the core...in my opinion...well done mate, sure a couple of bugs but they can be overcome with some manual editing of the templates
Thanks for the vote of confidence. I haven't been working on this lately due to a new laptop and moving over the past month and a half, hopefully I'll get to it some time soon now that I'm jobless, heh.

This add-on has plenty of inherent limitations unfortunately due to the very nature of how XenForo was written. I'm not criticizing XenForo, I think it's an absolutely beautifully coded piece of software, but this has been an interesting challenge. After doing this and digging through the XenForo code I can see why this wasn't included in the core out of the gate. I hope that at some point they do include it as a standard feature, and the XF team are free to use whatever code they wish from this add-on although I'm sure they could do way better. I doubt it'll make it in any time soon though.

I know the two main complaints with this add-on (aside from some bugs due to my boneheadedness of course) are template conflicts and the proper tab not being selected when you click on it. The first is due to how the navigation bar is actually rendered, which is a combination of generated templates as well as PHP code. As far as I can tell this is at least in part due to how the template parsing system works. The second is really due to how XenForo treats what tab is actually selected (majorSection of a route prefix being the same as a tabId). I've looked into making this work and I don't really think it's feasible for me unless I start modifying XenForo base code.

I've actually been considering putting my code up on a version control website and licensing it (at least to the extent that I can) under a permissive license so that other developers can take a look at it and maybe make improvements. I have sort of a partial version 2 made, although there's no clear upgrade path nor is it feature complete or tested. Feel free to PM me if you're interested.
 

UltimaOX

Active member
#52
Thanks for the vote of confidence. I haven't been working on this lately due to a new laptop and moving over the past month and a half, hopefully I'll get to it some time soon now that I'm jobless, heh.

This add-on has plenty of inherent limitations unfortunately due to the very nature of how XenForo was written. I'm not criticizing XenForo, I think it's an absolutely beautifully coded piece of software, but this has been an interesting challenge. After doing this and digging through the XenForo code I can see why this wasn't included in the core out of the gate. I hope that at some point they do include it as a standard feature, and the XF team are free to use whatever code they wish from this add-on although I'm sure they could do way better. I doubt it'll make it in any time soon though.

I know the two main complaints with this add-on (aside from some bugs due to my boneheadedness of course) are template conflicts and the proper tab not being selected when you click on it. The first is due to how the navigation bar is actually rendered, which is a combination of generated templates as well as PHP code. As far as I can tell this is at least in part due to how the template parsing system works. The second is really due to how XenForo treats what tab is actually selected (majorSection of a route prefix being the same as a tabId). I've looked into making this work and I don't really think it's feasible for me unless I start modifying XenForo base code.

I've actually been considering putting my code up on a version control website and licensing it (at least to the extent that I can) under a permissive license so that other developers can take a look at it and maybe make improvements. I have sort of a partial version 2 made, although there's no clear upgrade path nor is it feature complete or tested. Feel free to PM me if you're interested.
i really think you should get back to development on this addon. It really is a great addon and some guides on proper use would be great.

I just installed it to see how it owrks and i like most of what i see. Ill have to remake my addon tabs with your addon to move them, but that shouldnt be an issue.

Only issue i find is if i try to make a home page while useing Xenporta, it doesnt highlight. And of course to issues with having modual admin while on that page. i recall you mentioning it required some php, if you could go into that a bit more ide appreciate it.

Also ide love a good explination on what "Data" and "Extra Peramiters" are for.

but my only current request is ide like to know how to make my homepage link of www.mysite.com goto the "Home" tab i make for it and SHOW the subtabs under it. (again im useing xenporta so this is a bit problematic)

But otherwise, love the addon. if i cant get the homepage issues fixed, i will still definatly use this to add additional links to pages i need.

Thanks!
 

UltimaOX

Active member
#53
Unfortunately no. You could recreate the add-on navigation links in this, position it how you want it, and disable the add-on's navigation_tabs event listener.
how exactly d you disable NavTab listeners for addons?

this is the code i see in the navtab listener for my event addon.

Code:
<?php

class EWRatendo_Listener_NavTabs
{
    public static function listen(array &$extraTabs, $selectedTabId)
    {
        $permsModel = XenForo_Model::create('EWRatendo_Model_Perms');
        $perms = $permsModel->getPermissions();

        $extraTabs['events'] = array(
            'title' => new XenForo_Phrase('events'),
            'href' => XenForo_Link::buildPublicLink('full:events'),
            'position' => 'middle',
            'linksTemplate' => 'EWRatendo_Navtabs',
            'perms' => $perms,
        );
    }
}
 

dieketzer

Well-known member
#54
but my only current request is ide like to know how to make my homepage link of www.mysite.com goto the "Home" tab i make for it and SHOW the subtabs under it. (again im useing xenporta so this is a bit problematic)
im not sure how this mod changes the rules, but you can achieve what you are wanting pretty easily. i suspect you have disabled the portals home button to avoid the double-home buttons issue and are instead using the native xf home button. you need to do the opposite. enable the portal button, then in your xf options leave the home url blank and the button will disappear, plus the header graphic will link to the portal home automatically.

like this.
 

UltimaOX

Active member
#55
im not sure how this mod changes the rules, but you can achieve what you are wanting pretty easily. i suspect you have disabled the portals home button to avoid the double-home buttons issue and are instead using the native xf home button. you need to do the opposite. enable the portal button, then in your xf options leave the home url blank and the button will disappear, plus the header graphic will link to the portal home automatically.

like this.
no o, ive disabled the xf home, i had the portal home button enabled, but i want the nav manger to make a home button that works hah. it just doesnt seem to work, lke i can disable all the home buttons, make one in the nav manager and it wont work. =P
 
F

Floris

Guest
#59
Why is simple.

You have to start somewhere. You can't have everything in version 1.0 and then never have bugs, never have missing features, never have security issues, never have maintenance releases, never have user feature-requests, never have technology improvements, never have ...
 

Astrum

Active member
#60
Astrum are you still working on this add-on? Specially, about the bad and the ugly ones :)
Short answer is no.

Long answer is - and I'll get some flak for this - I'm waiting for XenForo 1.1. If this is included in 1.1 then great, although I don't think it will be. If it's not then I will be revisiting this idea, though not necessarily this add-on.