1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mysqli statement execute error

Discussion in 'Troubleshooting and Problems' started by Merijn, Jun 3, 2012.

  1. Merijn

    Merijn Member


    A member notified me that he had gotten an error while posting, and when I tried to, I could verify that the problem existed. The error I get is:

    Mysqli statement execute error : Field 'extra_data' doesn't have a default value

    I also inserted an screenshot of the error. What could this be, and more importantly, how do I fix it? The most recent changed I did was upgrading the BBCodeManager for the exploit that was in the old one, and some changes in my mysql configs. I disabled the addons that might have inflicted this, but I still can't post a reply.

    I hope someone can help me, because not being able to post on a forum isn't good. Thanks in advance!

    EDIT: More info

    Xenforo: 1.0.4.
    Theme: Flexile (Slightly modified)
    • Custom BBCode Manager v1.2.2
    • Find users sharing the same IP 0.0.2
    • Multiple Account Detection 1.0.1
    • Online Status 1.1
    • Tapatalk 1.1.2
    • [8wayRun.Com] XenHabla (IRC) 1.0.7
    • [8wayRun.Com] XenPorta (Portal) 1.4.4
    • [8wayRun.Com] XenUtiles (Tools) 1.1.4
    • [xfr] Infractions 1.0.2
    • [xfr] Merge Double User Post 1.2.0

    The backend is MySql, nginx and php-fpm.

    It's experienced by all users, no matter the browser.
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    The error refers to the Merge Double User Post addon. Try disabling that addon to see if that fixes the error.
  3. Merijn

    Merijn Member

    That doesn't help:


    And I also tried to disable all addons, but that didn't help either.
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Some of the line numbers aren't matching up for me.

    What version of XF?

    Run the file check to make sure it comes back clean:

    Admin CP -> Tools -> File Health Check
  5. Merijn

    Merijn Member


    Looks okay to me.
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    XF 1.0.4

    That's an old version. Can you upgrade to 1.1.2? I recommend that anyways.

    I examined the code for both versions and I see a difference that would explain this error. It appears to be a bug in 1.0.4. I can't find a report for it, but the code is fixed in 1.1.2.
  7. Learner

    Learner Member

    Sorry to but in here, but I also got errors today..
    reported from 3 members of th e10 odd logged in to the system.

    Xenforo error.jpg
  8. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That error names two addons:

    Learner likes this.
  9. Learner

    Learner Member

    Yeah I think you are right, I will try to check these addons and then report back :D Thanks a lot to you.

  10. Learner

    Learner Member

    I got the exact nature of the errors, it happens whenI slick on report !
    or simply speaking, when I want to report ( even for checking ) the feature, I get that error.
  11. Merijn

    Merijn Member

    I'm not going to try to upgrade it to see if that fixes it - I'm moving to a new domain and a new install in a day or so. Thanks for the replies though.

Share This Page