• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

MySqli errors in server log

Sway

Active member
#1
Every once in a while i see this error in my server error log. Not sure what it's about. My site does seem to be running a little slower than usual.

Code:
Error Info
Zend_Db_Statement_Mysqli_Exception: Mysqli prepare error: Table './ICC_Forum_Database/xf_search_index' is marked as crashed and should be repaired - library/Zend/Db/Statement/Mysqli.php:77
Generated By: [URL='http://www.iconomycraft.com/admin.php?users/nineaxe.277/']NineAxe[/URL], Today at 12:56 AM
Stack Trace
#0 /var/www/library/Zend/Db/Statement.php(115): Zend_Db_Statement_Mysqli->_prepare('????REPLACE DEL...')
#1 /var/www/library/Zend/Db/Adapter/Mysqli.php(381): Zend_Db_Statement->__construct(Object(Zend_Db_Adapter_Mysqli), '????REPLACE DEL...')
#2 /var/www/library/Zend/Db/Adapter/Abstract.php(478): Zend_Db_Adapter_Mysqli->prepare('????REPLACE DEL...')
#3 /var/www/library/XenForo/Search/SourceHandler/MySqlFt.php(110): Zend_Db_Adapter_Abstract->query('????REPLACE DEL...')
#4 /var/www/library/XenForo/Search/SourceHandler/MySqlFt.php(82): XenForo_Search_SourceHandler_MySqlFt->_pushToIndex('('thread', 1252...')
#5 /var/www/library/XenForo/Search/Indexer.php(44): XenForo_Search_SourceHandler_MySqlFt->insertIntoIndex('thread', 1252, 'my application', '', 1358036800, 723, 1252, Array)
#6 /var/www/library/XenForo/Search/DataHandler/Thread.php(34): XenForo_Search_Indexer->insertIntoIndex('thread', 1252, 'my application', '', 1358036800, 723, 1252, Array)
#7 /var/www/library/XenForo/Search/DataHandler/Abstract.php(227): XenForo_Search_DataHandler_Thread->_insertIntoIndex(Object(XenForo_Search_Indexer), Array, NULL)
#8 /var/www/library/XenForo/DataWriter/Discussion.php(613): XenForo_Search_DataHandler_Abstract->insertIntoIndex(Object(XenForo_Search_Indexer), Array)
#9 /var/www/library/XenForo/DataWriter/Discussion.php(550): XenForo_DataWriter_Discussion->_updateSearchIndexTitle(Array)
#10 /var/www/library/XenForo/DataWriter/Discussion.php(388): XenForo_DataWriter_Discussion->_indexForSearch(Array)
#11 /var/www/library/XenForo/DataWriter.php(1385): XenForo_DataWriter_Discussion->_postSave()
#12 /var/www/library/XenForo/ControllerPublic/Thread.php(772): XenForo_DataWriter->save()
#13 /var/www/library/XenForo/FrontController.php(310): XenForo_ControllerPublic_Thread->actionSave()
#14 /var/www/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#15 /var/www/index.php(13): XenForo_FrontController->run()
#16 {main}
Request State
array(3) {
  ["url"] => string(56) "http://iconomycraft.com/threads/my-application.1252/save"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(5) {
    ["prefix_id"] => string(1) "8"
    ["title"] => string(14) "my application"
    ["discussion_open"] => string(1) "1"
    ["_set"] => array(2) {
      ["discussion_open"] => string(1) "1"
      ["sticky"] => string(1) "1"
    }
    ["_xfToken"] => string(55) "277,1358038585,210c92b35397e5c014f271184716925ebafc95c7"
  }
}
 

Jake Bunce

XenForo moderator
Staff member
#2
Run a repair on that table (xf_search_index) using phpmyadmin. That should fix it.

Superficial corruption can happen as a matter of course when a service or server crashes or unexpectedly shuts down in the middle of a write. It's nothing to worry about unless it recurs, then you need to examine your uptime and logs to see what's going on.
 

Sway

Active member
#3
Run a repair on that table (xf_search_index) using phpmyadmin. That should fix it.

Superficial corruption can happen as a matter of course when a service or server crashes or unexpectedly shuts down in the middle of a write. It's nothing to worry about unless it recurs, then you need to examine your uptime and logs to see what's going on.
When i was running apache it ate up all my ram. That's probably why then :x