XF 2.2 MySQL Restore Passwords invalid


I'm testing backups and restore for my forum DB and when I tried to to a restore into a new database I ran in to the alarming result that my password for my admin account no longer worked. Is this normal behavior?

I was having problems resetting those passwords but I feel that might be related to something else. But before I proceed too deeply I was wondering why a DB restore might render the passwords invalid.

Thank you

Chris D

XenForo developer
Staff member
Not aware of anything related to a database backup/restore that would mess up the ability to read hashed passwords.

The only similar thing that would be common to experience is if you’re using a newer password hashing algorithm such as Argon2i or its newer variant Argon2id and the version of PHP in use after the restore is older and unable to support those or the underlying binaries for those hashing methods aren’t compiled to PHP.

You’d know if you’re using Argon2i(d) on the existing site because you will see a reference to it somewhere in src/config.php.


This is the entirely of what that file contains so it doesn't appear to be the case.


$config['db']['host'] = 'xxxxxxxxxx';
$config['db']['port'] = 'xxxxxxxxx';
$config['db']['username'] = 'xxxxxxxxxx';
$config['db']['password'] = 'xxxxxxxxxx';
$config['db']['dbname'] = 'xxxxxxxxxx';

$config['fullUnicode'] = true;

I'm going to recreate the testing environment to see if it happens again, I just wanted to check before hand whether it was normal or not for the passwords to get lost in a restore.