1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Multiple members complaining they aren't remaining / kept logged in - being logged out

Discussion in 'Troubleshooting and Problems' started by ProCom, Nov 24, 2013.

  1. ProCom

    ProCom Active Member

    A member started a thread saying that they are continually needing to log back into the forum even when they have the option checked to remain logged in.

    The reports of it happening are so far in IE 8, IE 10, & IE 11. The members have deleted cache, cookies, and logged in again, but they keep getting logged out.

    Any ideas on what could be the problem or what I can do to troubleshoot the issue?
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    What version of XF are you running?
  3. ProCom

    ProCom Active Member

    I'm on XenForo 1.2.2
  4. StealthBravo

    StealthBravo Member

    IE is insecure and slow. He shouldn't be using it in the first place.

    As for your actual question, what mods and applications are you using, if any? I would think that if this was an actual XF problem, it would have been reported and fixed a while ago.
  5. ProCom

    ProCom Active Member

    I agree on all counts (IE sucks and it must not be a global problem or others would be complaining).

    I don't have any mods installed that should be impacting login, but I'm wondering if any of my URL settings could be causing cookies to get confused. Would links with / without "www" confuse xF cookies and treat a member as logged in / logged off?
  6. StealthBravo

    StealthBravo Member

    I doubt it but I guess you never know when it comes to IE. I could try reproducing it to see if it might just be an issue on his side, but I'm on mobile right now, so I'm about as useless as a stick. If nobody else tries reproducing it for you, I'll give it a shot tomorrow as soon as I get a chance.
  7. ProCom

    ProCom Active Member

    Thanks for the offer. I'm digging a bit more into this with the users to see if they've bookmarked an www or non-www URL and what consistencies are between the 4 members reporting problems.
  8. AndyB

    AndyB Well-Known Member

    Yes that would be the problem.

    Add this to your .htaccess

    order deny,allow
    RewriteEngine on
    RewriteRule ^index\.html$ / [r=301,nc]
    RewriteCond %{http_host} ^yourdomain.com [nc]
    rewriterule ^(.*)$ http://www.yourdomain.com/$1 [r=301,nc]
    This would make sure "www" is always in the URL.
  9. Jeremy

    Jeremy XenForo Moderator Staff Member

    Yes, it will. However, you should update to 1.2.3, it has fixes for IE 11.
    Adam Howard likes this.

Share This Page