1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Moved to new host with Litespeed - 403 when saving in ACP

Discussion in 'Troubleshooting and Problems' started by kaieivindm, Apr 27, 2015.

  1. kaieivindm

    kaieivindm Active Member

    Hi,

    So I moved my webhotel to a new host, which has Litespeed compared to Apache for the old webhotel.

    I was then going to do somechanges in ACP, with my style and trying to press save - results in 403 error page.

    What I have tried:
    1) reverted to default htaccess from Xenforo
    2) removed ErrorDocument in my original htaccess file

    My cPanel error log shows this: (Each save is clearly showing 403 as seen below, ErrorDocument will dissapear with removing them from htaccess file)

    2015-04-28 00:01:26.595 [INFO] [IP:60923-0#APVH_spillforumet.no] File not found [/home/spillghf/public_html/403.shtml]
    2015-04-27 23:58:37.091 [INFO] [IP:60743-0#APVH_spillforumet.no] File not found [/home/spillghf/public_html/403.shtml]
    2015-04-27 23:57:47.268 [INFO] [IP:60716-0#APVH_spillforumet.no] File not found [/home/spillghf/public_html/403.shtml]
    2015-04-27 23:57:29.898 [NOTICE] [/home/spillghf/public_html/.htaccess:15] Unsupported ErrorDocument URL: default, must start with '/' or 'http'.
    2015-04-27 23:57:29.898 [NOTICE] [/home/spillghf/public_html/.htaccess:14] Unsupported ErrorDocument URL: default, must start with '/' or 'http'.
    2015-04-27 23:57:29.898 [NOTICE] [/home/spillghf/public_html/.htaccess:13] Unsupported ErrorDocument URL: default, must start with '/' or 'http'.
    2015-04-27 23:57:29.898 [NOTICE] [/home/spillghf/public_html/.htaccess:12] Unsupported ErrorDocument URL: default, must start with '/' or 'http'.
    2015-04-27 23:57:29.898 [NOTICE] [/home/spillghf/public_html/.htaccess:11] Unsupported ErrorDocument URL: default, must start with '/' or 'http'.
    2015-04-27 23:57:29.898 [NOTICE] [/home/spillghf/public_html/.htaccess:10] Unsupported ErrorDocument URL: default, must start with '/' or 'http'.
    2015-04-27 23:57:29.898 [NOTICE] [/home/spillghf/public_html/.htaccess:9] Unsupported ErrorDocument URL: default, must start with '/' or 'http'.
    2015-04-27 23:57:29.898 [NOTICE] [/home/spillghf/public_html/.htaccess:8] Unsupported ErrorDocument URL: default, must start with '/' or 'http'.
    2015-04-27 23:46:45.558 [NOTICE] [/home/spillghf/public_html/.htaccess:33] Unsupported ErrorDocument URL: default, must start with '/' or 'http'.
    2015-04-27 23:46:45.558 [NOTICE] [/home/spillghf/public_html/.htaccess:32] Unsupported ErrorDocument URL: default, must start with '/' or 'http'.

    Is there something I have to check via cPanel? Something I have to add/remove to my htaccess file?

    /edit: it seems this is specifically only when saving style settings. all other saves in acp is ok. is it permissions on the directory? files then?

    Thanks!
     
  2. The Forum Heroes

    The Forum Heroes Well-Known Member

    Make a 403.shtml file, that will fix the errors.
     
  3. kaieivindm

    kaieivindm Active Member

    With 640/644 permissions? Does it need content?

    /edit: result

    upload_2015-4-28_1-9-5.png
     
  4. The Forum Heroes

    The Forum Heroes Well-Known Member

    0644 is fine, nope can just touch it
     
  5. kaieivindm

    kaieivindm Active Member

    But this just removes my 403 in error log correct? Not the actualy issue with why I get it and cant save style settings in ACP?
     
  6. kaieivindm

    kaieivindm Active Member

    All fixed.

    Was a server setting in Litespeed the host had to change.
     

Share This Page