• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Mobile Suite for XenForo

Mobile Suite for XenForo 1.0.13

No permission to download


Active member
@Alfa1 @Floyd R Turbo There was a config issue with the actual forum (not the add-on) that was causing a lot of different things to go haywire, our add-on included; found out what you meant when you said the box was in the footer, that is not normal behavior for the plugin.

The config issue was just fixed so everything should be operating normally as of now.


Well-known member
Turned this on for 1 usergroup (admin) to test and was thrown the following errors (appears to have locked up other usergroups):

Error: Call to a member function getId() on boolean - WebPush/_source/turnkeymobileapps/WebPush/src/Runtime.php:169
Generated By: Unknown Account, Today at 9:18 AM
Stack Trace
#0 /home/oakleyfo/public_html/WebPush/_source/turnkeymobileapps/WebPush/src/Runtime.php(145): WebPush\Runtime::userAuthToken(Array)
#1 /home/oakleyfo/public_html/library/WebPush/Listener.php(81): WebPush\Runtime::headInclude(Array)
#2 /home/oakleyfo/public_html/library/XenForo/CodeEvent.php(58): WebPush_Listener::template_hook('page_container_...', '\n\t<meta charset...', Array, Object(XenForo_Template_Public))
#3 /home/oakleyfo/public_html/library/XenForo/Template/Abstract.php(285): XenForo_CodeEvent::fire('template_hook', Array, 'page_container_...')
#4 /home/oakleyfo/public_html/internal_data/templates/S.2,L.1,PAGE_CONTAINER.php(356): XenForo_Template_Abstract->callTemplateHook('page_container_...', '\n\t<meta charset...', Array)
#5 /home/oakleyfo/public_html/library/XenForo/Template/Abstract.php(260): include('/home/oakleyfo/...')
#6 /home/oakleyfo/public_html/library/XenForo/Template/Abstract.php(191): XenForo_Template_Abstract->_renderInternal('/home/oakleyfo/...', Array)
#7 /home/oakleyfo/public_html/library/XenForo/Template/Public.php(110): XenForo_Template_Abstract->render()
#8 /home/oakleyfo/public_html/library/XenForo/ViewRenderer/HtmlPublic.php(140): XenForo_Template_Public->render()
#9 /home/oakleyfo/public_html/library/XenForo/FrontController.php(639): XenForo_ViewRenderer_HtmlPublic->renderContainer('\n\n\n\n\n\n\n\n\n\n\n\n\n<f...', Array)
#10 /home/oakleyfo/public_html/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_View), Object(XenForo_ViewRenderer_HtmlPublic), Array)
#11 /home/oakleyfo/public_html/index.php(13): XenForo_FrontController->run()
#12 {main}
Request State
array(3) {
  ["url"] => string(53) "https://www.oakleyforum.com/account/alert-preferences"
  ["_GET"] => array(0) {
  ["_POST"] => array(0) {

Floyd R Turbo

Well-known member
Can you please use a version number in the filename when you update the listing? It always downloads as "xenforo-1.x.zip which in and of itself doesn't really follow in line with what most poeple do for a naming convention. You should at least have the filename include the actual name of tha addon and version number. I'm one of those people that hoards old versions (disk space is cheap) and also sometimes I only get around to doing updates monthly so if more than one version comes out between updates I like to be able to check that quick. I can't tell any of that with yours.

I would recommend using this format: "addon-tma-mobile-push-notifications-xenforo-1.0.4.zip" then just update the version number in the title with each update.

Just a friendly suggestion.


Active member
turnkeymobileapps updated Mobile Push Notifications for XenForo with a new update entry:

Fix: Non-delivery of Notifications

We have discovered a major issue that was causing push notifications to not be sent. This fix does not require an update, but:
  • Users not receiving alerts must clear their cookies and log back in
  • If your plugin was uninstalled, contact us for a license key to re-activate it (required)
We also discovered an issue that either delays or prevents activation of our service; this issue is caused by Cloudflare, and you must whitelist this URL:

Read the rest of this update entry...
I installed this app. However, I found it is not ready yet for production use. The main shortcomings are:

1) It cannot be translated properly. The text and buttons for the main dialog, which asks whether the user wants to accept push notifications or not, can't be translated. There are no phrases for that text. That's the same as @MattiGB asked above. If you need to buy a support subscription for such a basic need, it doesn't promise any good for the future use.

2) The app installs by default as "Allow" permission for all the usergroups.
That's not a good practise. By default it should be "Not set (no)". The most addons have it that way.

3) The addon populates all the Alert Preference settings (all user groups) with a selection box "Receive Push Notifications". It does it also for user groups, which have the permission set as "Not set (no)" That's somewhat misleading. The option should only be visible if the permission is set as "Allow".

I hope these rough edges will be corrected soon. Then I'll consider installing this addon again.
After installing and reading all the documentation, one thing isn't clear. For Android Chrome users, does anything need to be done? For users that don't use, have, or want Facebook, how can we get this to work? When I first got the notification for push, it only allowed a Facebook messenger login. No different on Android device.


Active member
TMA updated Mobile Suite for XenForo with a new update entry:

Mobile/Web Push is now Mobile Suite

Mobile/Web Push is now Mobile Suite! Mobile Suite turns your forum into a progressive web app; changes:
  • You can now add your forum to the home screen
  • Your forum can now act as a stand-alone app
  • Added Push Notifications for older Android devices
  • Members who waived push notifications now have the option to request them at a later time
  • Several bug fixes
For more details, click here.
Read the rest of this update entry...