Minimum Posts

Minimum Posts 1.0

No permission to download

AndyB

Well-known member
AndyB submitted a new resource:

Minimum Posts - Requires a minimum number of posts to view threads.

Description:

Requires a minimum number of posts to view threads.

The admin selects certain forums where a minimum number of posts are required for a member to view the threads in that forum.

(Example of Options page)

View attachment 130586

(Example of Error message)

View attachment 130587

Installation:
  1. Download minimumposts_v1.0.zip and unzip it.
  2. Upload the Andy folder to your server. The correct location is library/Andy.
  3. From your Admin...

Read more about this resource...
 

KhanTastic

Active member
i like this addon a lot and want to have but I get this error Callback Andy_MinimumPosts_Listener::Thread is invalid (Invalid Class). when I try to import the XML file in ACP.
Anyone facing the same issue? I am using the current XF version.
 

Gregsta

Member
I am new to all this and thank you for your help. I have only installed Xenforo about 5 hours so its going to take me time to figure all this out. it's maybe a little bit more complex than mybb to use, what i have been use to using.
 

ASap

Active member
I'm having this permission issue:

Code:
Server Error

include(/home/forum/domains/public_html/library/Andy/MinimumPosts/Listener.php): failed to open stream: Permission denied

    XenForo_Application::handlePhpError() in XenForo/Autoloader.php at line 119
    XenForo_Autoloader::autoload() in XenForo/Autoloader.php at line 119
    XenForo_Autoloader->autoload()
    spl_autoload_call()
    class_exists() in XenForo/Helper/Php.php at line 62
    XenForo_Helper_Php::validateCallback() in XenForo/Helper/Php.php at line 114
    XenForo_Helper_Php::validateCallbackPhrased() in XenForo/DataWriter/CodeEventListener.php at line 101
    XenForo_DataWriter_CodeEventListener->_preSave() in XenForo/DataWriter.php at line 1446
    XenForo_DataWriter->preSave() in XenForo/DataWriter.php at line 1385
    XenForo_DataWriter->save() in XenForo/Model/CodeEvent.php at line 405
    XenForo_Model_CodeEvent->importEventListenersAddOnXml() in XenForo/Model/AddOn.php at line 316
    XenForo_Model_AddOn->importAddOnExtraDataFromXml() in XenForo/Model/AddOn.php at line 226
    XenForo_Model_AddOn->installAddOnXml() in XenForo/Model/AddOn.php at line 169
    XenForo_Model_AddOn->installAddOnXmlFromFile() in XenForo/ControllerAdmin/AddOn.php at line 236
    XenForo_ControllerAdmin_AddOn->actionUpgrade() in XenForo/FrontController.php at line 347
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in /home/forum/domains/public_html/admin.php at line 13
Does anyone have any idea what's wrong?

I have recursively set data and internal data folder to 777.
 
Top