1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Minifier [Deleted]

Discussion in 'Add-on Releases' started by euantor, Oct 11, 2013.

  1. euantor

    euantor Well-Known Member

    euantor submitted a new resource:

    Minifier - Minify your forum's HTML output

    Read more about this resource...
     
  2. RaymondCC

    RaymondCC Member

    Finally!
     
    euantor likes this.
  3. DRE

    DRE Well-Known Member

    Can you show an example of this in action please?
    Can you show an example of this in action please?
     
  4. euantor

    euantor Well-Known Member

    I'll install it on my site just now as a demo.
     
  5. euantor

    euantor Well-Known Member

    MattW likes this.
  6. DRE

    DRE Well-Known Member

    Okay I see it in the page source. Cool!

    Does this affect the templates in AdminCP whenever we edit our Templates?

    Does this speed the site up any?
     
  7. euantor

    euantor Well-Known Member

    The minification is done before outputting the page, so templates are stored entirely as is. It might speed the site up by a small degree as it means there is less to download on the client die. It's recommended by services such as YSlow and PageSpeed.
     
  8. MattW

    MattW Well-Known Member

    Many thanks for this, just installed it now (y)
     
    euantor likes this.
  9. Luke F

    Luke F Well-Known Member

    You can't strip whitespace around non-block level elements without causing visual glitches (iirc things like thread counts lose spacing on forum home)

    Also it's overall not a good idea to do this with PHP as it's too slow - best left to something like ngx_/mod_pagespeed where it can be done efficiently enough to be worth it overall

    Feel free to copy the code in http://xenforo.com/community/resources/xf-optimise.118/
     
    Adam Howard and euantor like this.
  10. euantor

    euantor Well-Known Member

    I hadn't thought about the issue with non-block level elements. I'll have to think of a way to expand the code to work in those instances.
     
  11. MattW

    MattW Well-Known Member

    Just noticed that while running it on my site.
     
  12. euantor

    euantor Well-Known Member

    Adam Howard and MattW like this.
  13. DRE

    DRE Well-Known Member

    Not working for me.
     
  14. MattW

    MattW Well-Known Member

    Works fine for me on two different sites. Only issue is even with the latest update, I'm still getting gaps missing in the UI.X style

    Disabled:
    upload_2013-10-11_23-42-9.png

    Enabled:
    upload_2013-10-11_23-42-54.png
     
  15. euantor

    euantor Well-Known Member

    Him, I'll have to look into that. It seemed fixed for me on my ui.x install.

    @DRE what about it isn't working?
     
  16. MattW

    MattW Well-Known Member

    If you look here: http://www.xendevelop.com/

    Hover over the node to view the stats, and you have no space between the icons on the numbers.
     
    euantor likes this.
  17. euantor

    euantor Well-Known Member

    Thanks. Looks like the Minify library isn't quite perfect either :(
     
  18. maxicep

    maxicep Active Member

    I m getting this error on server error log

    Fatal Error: Maximum execution time of 30 seconds exceeded
    Today 04:49 - library/Minify/HTML.php:113

    ErrorException: Fatal Error: Maximum execution time of 30 seconds exceeded - library/Minify/HTML.php:113

    Why ?
     
  19. euantor

    euantor Well-Known Member

    Strange, that's a class shipped with XenForo. It's taking too long to execute the minification process.
     
  20. maxicep

    maxicep Active Member

    So, how can i fix this ? I m getting this error about 10-15 times in a day
     

Share This Page