1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Merged two threads now they're both gone

Discussion in 'Troubleshooting and Problems' started by ibenick, May 7, 2012.

  1. ibenick

    ibenick Active Member

    I attempted to merge two threads today and the result was that both disappeared. I've searched my site high and low and can't find them. I've read a bit about a current bug related to deleting threads but this isn't the same, right? Any ideas how I can get them back?
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Check the log:

    Admin CP -> Tools -> Moderator Log

    That should have a link to the thread.
  3. ibenick

    ibenick Active Member

    It shows the merge and then it shows that I deleted it but I definitely did not delete it... ideas?

  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Well that explains why you can't find the thread. Maybe you unintentionally selected the delete option after the merge. I just tested a merge on my forum to make sure it's not a bug. The thread was not deleted in my test.

    You will have to go into a backup to get the deleted thread. It involves isolating the xf_thread and xf_post records and restoring only those records from the backup. That will preserve the thread and its posts. Other things like attachments and watch records are stored separately and require extra effort to restore.
  5. ibenick

    ibenick Active Member

    Thanks, Jake. Not worth dealing with the restore in this case, still don't get what happened though. I went back and recreated but there was no possible option to delete anything...

Share This Page