• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Max Execution Time Error when installing

#1
Maximum execution time of 120 seconds exceeded in D:\home\site\wwwroot\library\Zend\Db\Statement\Mysqli.php on line 70

At first I thought this was a php max execution time issue. I spent last week working with Azure support to lift the execution time and they were able to do so. Unfortunately, even with max_execution_time = 300, I'm still getting this error. I don't think it has to do with the PHP configuration. Can someone help me out? Am I able to manually go into that php file and increase the max execution time for the purposes of installing?
 

Brogan

XenForo moderator
Staff member
#2
We have had a few reports similar in nature to this related to Azure.

Unfortunately our troubleshooting all points to it being an Azure issue and it's not something we can resolve or workaround via our code.

You can try contacting your host and ask them to investigate and possible try increasing the max execution time.

Other than that, we could only suggest moving to a different host.
 
#3
I tried to take a look one more time and the timeout happens on this line:

$this->_stmt = $mysqli->prepare($sql);

which is trying to prepare SQL statement according to http://php.net/manual/en/mysqli.prepare.php

Maybe the SQL query is too large or the connection to the server is having an issue. At this moment it actually looks like the timeout is coming from that SQL client code.
From last post here: https://social.msdn.microsoft.com/F...on-in-azure?forum=windowsazurewebsitespreview

Right now it seems like xenForo and Azure support are bouncing back and forth, but that line is where the issue happens (per his investigation). Can you guys look into it? I've filed a support ticket with Azure also.