XF 1.5 MariaDB upgrade. Cannot downgrade. Old forums 1.5 version stuck

JoePTP

Member
Hello,

I have a few forums with some running the old 1.5 version. I am hosted through Liquid Web. I guess the overnight update of the MariaDB caused a lot of issues with a lot of people including myself. I had the MariaDB updated and moved my forums onto the PHP 7.4 and all is well with my forums running version 2.0+ but now my older version forums are broken and I cannot downgrade my MariaDB according to Liquid Web. It seems Xenforo 1.5 earlier versions cannot go past the PHP 5.6.

How can I upgrade my older forums without having access to anything to do the upgrade? When I try to upgrade it, I get this error:

Fatal error: Uncaught ErrorException: array_key_exists(): Using array_key_exists() on objects is deprecated. Use isset() or property_exists() instead in /home/joeptp/public_html/site.com/library/Zend/Registry.php:206 Stack trace: #0 /home/joeptp/public_html/site.com/library/Zend/Registry.php(206): XenForo_Application::handlePhpError(8192, 'array_key_exist...', '/home/joeptp/pu...', 206, Array) #1 /home/joeptp/public_html/site.com/library/Zend/Registry.php(183): Zend_Registry->offsetExists('config') #2 /home/joeptp/public_html/site.com/library/XenForo/Helper/File.php(284): Zend_Registry::isRegistered('config') #3 /home/joeptp/public_html/site.com/library/XenForo/Error.php(78): XenForo_Helper_File::getInternalDataPath() #4 /home/joeptp/public_html/site.com/library/XenForo/Application.php(381): XenForo_Error::unexpectedException(Object(ErrorException)) #5 [internal function]: XenForo_Application::handleException(Object(ErrorException)) #6 {main} thrown in /home/joeptp/public_html/site.com/library/Zend/Registry.php on line 206


Any advice on what I can do now?
 

MattW

Well-known member
Why is your host telling you it can’t be downgraded? I’ve downgraded 40+ servers since this started, with no issues during the process.
 

MattW

Well-known member
Or when you say that you also had it updated, did you go from 10.2 to 10.3? If that’s what they did, then you probably won’t be able to safely downgrade it again.
 

JoePTP

Member
This is basically what they told me:

Unfortunately we cannot roll back the upgrade. The best option in this situation is to upgrade the php version the site is using to 7.3 or higher.

Do I have any other options to get the forums back up or upgraded somehow?
 
Top