1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

Looking for beta tester: Move thread option 'update timestamp'

Discussion in 'Resource Discussions [Archive]' started by Floris, Nov 6, 2011.

  1. Floris

    Floris Guest

    On behalf of XenFans.com Fuhrmann has done a wonderful job turning a spec/prototype into a working alpha plugin for XenForo 1.1.0 beta 4. And we're prepping it for a release. But before we do that our team and a few beta testers can get an early copy.

    The plugin adds the ability for an admin (and/or moderator) to update the timestamp to 'a moment ago' when moving a thread.

    When a thread is moved (thread tools > move thread [you get an overlay]) it shows a checkbox with [update timestamp?].

    Screen shot 2011-11-06 at 4.01.15 AM.png

    admin options:
    Screen shot 2011-11-06 at 4.14.56 AM.png

    I hereby invite you to give this a try on your board. This is the version I currently run live on XenFans.com

    Just upload the files, import the .xml and go through the settings.

    Known Issues: admin should be selected by default, it might be possible it's not doing this (yet).

    This is coded on and made for xenforo 1.1.0 beta 4, no other versions (including 1.0) have been tested.

    Looking for: Typing errors, broken links, settings that don't work, missing links / images, general or specific feedback, complaints, and suggestions.

    It was intended to release this to only premium users, this won't be the case, it will be a free download to everybody.

    If you're interested in helping test this release, give some feedback/suggestions, please let me know.
    Andrej and Mikey like this.
  2. Floris

    Floris Guest

    I've received a few requests, I got room for one more.
  3. James

    James Well-Known Member

    Nice idea, and I created something similar, but remember that you need to update the timestamp of the thread and the timestamp of the first post.
  4. Fuhrmann

    Fuhrmann Well-Known Member

    We did that :)
    Floris and James like this.
  5. James

    James Well-Known Member

    In my testing, when rebuilding thread info, the thread info is reverted with the thread rebuild. Did you try it?
  6. Fuhrmann

    Fuhrmann Well-Known Member

    That's strange.

    I moved a old thread. The timestamp updated.
    Then I rebuilded the thread info, but the thread still have the last timestamp. This was the steps that you did?
  7. James

    James Well-Known Member

    I didn't test it with this add-on, but these are the steps I did personally:

    Updated thread info using DataWriter (timestamp)
    Rebuilt thread info via tools/rebuild-caches

    The thread I updated then reverted to the old timestamp.

    It's possibly because I didn't update the post timestamp too, so when rebuilding it compared them and saw they didn't match, I've not looked too much into it. Just throwing out some issues I had :p
  8. Fuhrmann

    Fuhrmann Well-Known Member

    Oh! Got it!

    I solved this just by updating the first post timestamp, as you said.
    James likes this.
  9. Floris

    Floris Guest

    Yeah, I tried redirects, rebuilding caches, moveing, and rebuilding.
    I could not find an error. But, that's why we're looking for more testers, to find the unexpected.
    James and Fuhrmann like this.
  10. Floris

    Floris Guest

Share This Page