Logo Essentials

Logo Essentials 1.0.0.1

No permission to download

Nulumia

Well-known member
Nulumia submitted a new resource:

Logo Essentials - Center your logo, specify navigation small logo URL, set size dimensions and more!

View attachment 216185

This simple addon provides useful settings and properties for the Xenforo logo, addressing the most often asked questions about logo customization.

No more having to search Google or Xenforo.com, or pasting CSS into your theme to make basic changes!

Features:
  • Specify optional URL path for the navigation small logo image (if left blank, it will use the main logo as normal in the mobile nav)
  • Center the header logo
  • Specify max-height...

Read more about this resource...
 

Nulumia

Well-known member
So with this add-on we can set different logo for mobile?
Yes! It adds an additional URL logo path right below the normal logo, and retina logo 2x entries in Style Properties -> Basic options :)

If left blank, it will just behave as normal and show the desktop logo on mobile.
 

Veer

Well-known member
ok, great :)

and what about the logo in navigation bar, can you show a screen ? thanks
 

Nulumia

Well-known member
ok, great :)

and what about the logo in navigation bar, can you show a screen ? thanks
This addon doesn't move the logo into the navigation bar, but it will allow you to specify the logo that displays there normally on mobile.

I'm releasing a separate Advanced Header addon soon, which offers a whole new combined logo/navigation header and dozens new settings. This will be a paid (but very affordable) addon while this one remains free :)
 

Nulumia

Well-known member
Does this add-on work with custom themes, or is it only for the default XF theme?
It should work with many custom themes, as long as they haven't considerably customized the templates around the logo. Such a case would be harmless though, and the addon would simply not apply. If any conflicts are posted back here, they can be fixed in a new update!
 

Nulumia

Well-known member
When I try to use this add-on it only gives me errors. What should I check?

View attachment 216241
My first guess would be an addon conflict, but would you mind pasting the full error it gives in your browser console?
When encountering this message again, open the Inspector by right-click -> "Inspect", or by pressing:

Chrome: Ctrl+Shift+J
Firefox: Ctrl+Shift+K
Edge: F12
Opera: Ctrl+Shift+C

Then click on the "Console" tab and grab the message there. You may paste via PM if preferred.
 

AngelArs

Active member
All I see is a "Failed to load resource. Server responded with a status of 403" error. Possibly a javascript error?

Only place I'm seeing this error is in Style Properties.
 

Nulumia

Well-known member
Does it mention the file or location which is causing the 403 error? Sounds like a mod_security issue at your host, but I'd be curious why it would be related to the addon.
 

AngelArs

Active member
I didn't see a file name mentioned. I disabled all add-ons and it's still doing the same thing. It appears to be a Xenforo or a server issue so I will move this to the main forum. Thank you for responding so quickly. It is appreciated.
 

Nulumia

Well-known member
I didn't see a file name mentioned. I disabled all add-ons and it's still doing the same thing. It appears to be a Xenforo or a server issue so I will move this to the main forum. Thank you for responding so quickly. It is appreciated.
If it helps, many threads here at Xenforo regarding similar issues turn out to be mod_security related, not sure if that's your issue but may help in searching. Best of luck,
 

AngelArs

Active member
It apparently has to do with these server errors;

Not sure what it's trying to tell me though...
 

Attachments

  • servererrors.png
    servererrors.png
    79.3 KB · Views: 10

Nulumia

Well-known member
Are you using an addon that customizes the forum nodes, such as TH Nodes? There's nothing like that in Logo Essentials addon.
 

AngelArs

Active member
UPDATE:

The server errors posted above are being caused by the Xmagazine theme purchased at DohTheme.

They were contacted several days ago but still no contact from them.
 

Nulumia

Well-known member
UPDATE:

The server errors posted above are being caused by the Xmagazine theme purchased at DohTheme.

They were contacted several days ago but still no contact from them.
Thanks for the clarification and glad at least you were able to track the errors down. Best luck in getting things resolved,
 
Top