1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Link-Forum font style - how to change it to be the same as Forum style

Discussion in 'XenForo Questions and Support' started by erich37, Feb 27, 2011.

  1. erich37

    erich37 Well-Known Member

    for some odd reason, the font style (bold, color, ...) at the Link-Forum is quite different to the font-style of a regular Forum.
    I mean the name-text and the description-text of the Link-Forum is too bright for my users.

    How do I make the text and font-style of the Link-Forum-Node to be looking the same as on the Forum-Node ?

    Thanks!
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    It uses the same CSS as other node titles so I'm not sure what you mean.

    Do you have a heavily customised style?
     
  3. erich37

    erich37 Well-Known Member

    I just use the default XF style, no customizations at all.

    But if you have a "description-text" within one of your Forums and also have a description text in one of your "Link-Forums", then you will see that the font-color and thickness is quite different.
    I was looking of where to change this in ACP, but could not find any option for this.

    I do not understand why the font-style of the "Title" and "Description" of a "Link-Forum" is different to a regular "Forum" ?

    see image attached:
    note: this is how it shows when viewing as a guest (status: not logged in)

    font_style_different.png
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Can you provide a link or a screenshot?

    There is a link forum here on XenForo.com (Random Questions Answered) and it appears identical to the others.

    link.PNG
     
  5. erich37

    erich37 Well-Known Member

    you do not have entered any "description-text" for your regular Forums, that´s why you do not see the difference........


    *******
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    The forum title is bold because it has unread posts.
    If you mark it as read it will appear the same.

    For the description text, just change it in Style Properties -> Forum List -> Node Description
     
  7. erich37

    erich37 Well-Known Member

    what do you mean with "unread posts" ? I am actually viewing the page as guest, so actually being "logged out"..... so "unread" does not matter when being logged out.
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    Forum titles always appear bold to guests.

    If you want link titles to appear as bold, just click the B button in Style Properties -> Forum List -> Node Title

    Be aware though, all node titles will always show as bold.
     
  9. erich37

    erich37 Well-Known Member

    yeah, but why do "Link-Forum" titles do not appear in bold to guests ?
    That is the issue I want to fix. I would like to have the title of the "Link-Forum" also to show in bold, which is better readable for users.
     
  10. Brogan

    Brogan XenForo Moderator Staff Member

    Pages and link forums don't contain threads or posts and therefore have no read or unread marking data.
     
  11. erich37

    erich37 Well-Known Member

    I do not want to have those to "always" show in bold.
    I just want to have the font-style of the Title of the "Link-Forum" in bold......and the font-style of the "description" of the Link-Forum in black.

    reason: readability
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

    I've explained how to do the description text in post #6.

    I've also explained why it doesn't show as bold in post #10.
    I'm not sure anything can be done to make pages and link forum titles bold, without affecting normal forum titles.
    You could possibly use a node-id conditional but that seems a bit over the top.
     
  13. erich37

    erich37 Well-Known Member

    o.k., thanks !
     

Share This Page