XF 2.2 Latest Posts Resources Prefixes

Cl0udzz

Member
I would like the "Latest Posts" widget to show the prefixes of the created resources.

When I create a new resource, it is displayed directly in one of the forum nodes. I have different categories there. I don't understand why these are not automatically displayed there when I create a new resource.

So far only my avatar is displayed and the title of the created resource but the prefixes from the resources are not showing up.

Does someone know why and how to do that?
i would like to have it almost exactly like the "Latest Resources" widget
 
Last edited:

Brogan

XenForo moderator
Staff member
It doesn't do it automatically because resources and threads can have different prefixes and thread prefixes are not available to resources, and vice versa.

Do specific resource categories post in specific forums only?

If so, a prefix can be set per forum when creating a resource.
1636395518433.png

If different resources (and prefixes) are posted in the same forum then that won't work.
 

Cl0udzz

Member
It doesn't do it automatically because resources and threads can have different prefixes and thread prefixes are not available to resources, and vice versa.

Do specific resource categories post in specific forums only?

If so, a prefix can be set per forum when creating a resource.
View attachment 259927

If different resources (and prefixes) are posted in the same forum then that won't work.
First of all, thanks for that fast response.
Appreciate that !

specific resources post in specific forums only, thats correct brogan.
Where do i find that option "Automaticlly created thred prefix:" ?

edit
oh sorry i understand it wrong.
I will take a look at it now.
Give me a moment.
 
Last edited:

Cl0udzz

Member
okay now i figure it out a little bit.
I allready have special resource prefixes and some thread prefixes.

It will only show the prefixes on the "Latest Posts" widget when i edit an thread thats automatically created when i create a new resource.
But how can I set it up so that this happens automatically?
 

Brogan

XenForo moderator
Staff member
The prefix is applied to the thread when the resource is created and the resource category has thread creating with prefix applied

The prefix should show in new posts and what's new.

For any existing threads before you made the changes, they would need to be edited and the prefix applied manually.
 

Cl0udzz

Member
i can set an default thread prefix but its showing only in the prefix area when i edit the thread.
there must be a option to let it show when i create a resource.
The default thread prefix is set. So something missed here think
 
Top