1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Kotomi - Generic script bridge 0.0.1

Developer sample for basic script embedding

  1. Luke F

    Luke F Well-Known Member

  2. dragonhib

    dragonhib Member

    Hi Darkimmortal !
    Have a problem with Kotomi and TaigaChat :
    Works when TaigaChat is deactivated... Maybe you can help me ?
     
  3. dragonhib

    dragonhib Member

    Ok resolved by unchekcking the global hook in options page
     
  4. account8226

    account8226 Guest

    I don't get how to use it ?
     
  5. boban

    boban Well-Known Member

    dragonhib likes this.
  6. Hardcore

    Hardcore Active Member

    Darkimmortal -

    Finally got this working, for the most part. I dig it. Awesome resource.

    Questions. How do I ...
    1. Set the page title and meta description/keywords?
    2. Set the breadcrumbs or disable them for these external pages?
    3. Disable the search bar for these external pages or swap it out with my own search?
    I also noticed that this is fixed with "NoSidebar" ...
    HTML:
    <html id="XenForo" lang="en-US" dir="LTR" class="Public LoggedIn NoSidebar" xmlns:fb="http://www.facebook.com/2008/fbml">
    Is there anyway to allow XenForo to set it as normal? I'm looking to replicate some sidebar look and feel using XenForo's css.

    Thanks!
     
  7. Luke F

    Luke F Well-Known Member

    You should be able to do most of those by extending the code to allow for custom template names to be passed through (add extra param to runKotomi and use it on line 24, and edit kotomifooter to pass it through from your code) and then duplicating and modifying the dark_kotomi template to your needs

    If you set the container boolean to false you could recreate the entire PAGE_CONTAINER template in one of your duplicate templates to give you even more fine grained control
     
  8. Hardcore

    Hardcore Active Member

    Thanks. Still trying to wrap my head around XenForo. Much of this is over my head as a result, but I'll do some more research on how to tweak all of this. Any examples would be much appreciated too.

    And thanks again for creating this addon!
     
  9. account8226

    account8226 Guest

    Hey, it's amazing your addon is really amazing !

    But when I use PHP variables (like $test = date(y);) I have errors like that :

    Fatal error: Uncaught exception 'ErrorException' with message 'ini_set() has been disabled for security reasons' in /home/myforum/public_html/library/XenForo/Error.php:106 Stack trace: #0 [internal function]: XenForo_Application::handlePhpError(2, 'ini_set() has b...', '/home/myforum/...', 106, Array) #1 /home/myforum/public_html/library/XenForo/Error.php(106): ini_set('display_errors', true) #2 /home/myforum/public_html/library/XenForo/Error.php(98): XenForo_Error::_getPhrasedTextIfPossible('An unexpected e...', 'unexpected_erro...') #3 /home/myforum/public_html/library/XenForo/Application.php(295): XenForo_Error::unexpectedException(Object(ErrorException)) #4 [internal function]: XenForo_Application::handleException(Object(ErrorException)) #5 {main} thrown in /home/myforum/public_html/library/XenForo/Error.php on line 106

    I have this error when I use things like that :
    $date2 = date(y,'-',m,'-',d);
    echo $date2;

    Or like that
    $test = $_POTS['name'].$_POST['test'];

    Regards
     
  10. Luke F

    Luke F Well-Known Member



    Ask your host to enable it
     
  11. account8226

    account8226 Guest

    I can enable it myself I am on a dedi, but don't want to, for security reason...
     
  12. Andy.N

    Andy.N Well-Known Member

  13. Ingenious

    Ingenious Well-Known Member

  14. karoshio

    karoshio Active Member

    Is there any reason why custom stylesheets would not work? I have it all working but no styling for the script.
     
  15. Clark

    Clark New Member

    Hey guys,

    I'm currently working on my Xenforo forum and wanted to create external pages (under a different domain) for other websites (all under one installation of course) - to make use of my design and the functionality of the software so I thought I'd check this plug-in out and give it a go.

    I think I'm on the right track but if anyone could help me it would be appreciated. I'm currently having trouble with finding the Zend_Registry. I have spent about three to four hours trying to get it to work but thought someone with more expertise in this area would be better to assist. I'm new to the software, so still learning how it works.

    I'm stuck at
    Code:
    Fatal error: Class 'Zend_Registry' not found in /home/myusername/public_html/mydomain/library/XenForo/Application.php on line 11
    Again, if any of you could take the time to help me it would be much appreciated.

    Thanks. :)
     
  16. simbolo

    simbolo Well-Known Member

    Zend_Registry is located in library/Zend/Registry.php if you're looking for the file. If it doesn't exist are you sure all files have been uploaded?
     
    Clark likes this.
  17. Clark

    Clark New Member

    Yes, I thought so. This file is were it should be located but it's saying the file is not there for some reason. Can you tell me how the file structure should be for this plug-in as maybe I have that wrong? Although, I'm following the fatal errors and putting the files in those folders. Seems strange, been really trying to get it to work for quite a considerable amount of time.

    Again, thanks. :)
     
  18. bambua

    bambua Well-Known Member

    Most of the time when that comes up, you have the path set wrong in the bridge. Can you paste in here what you set up your path to and where the files actually are on your server? (the bridge file and your xenforo installation?)
     
    Clark likes this.
  19. Clark

    Clark New Member

    Hey, I've made some progress. I now have it coming up as the page but it's blank and all the links are wrong. http://communehost.com. The way I have it set is this Library (All files within mods etc) | Styles | Zend. I have also tried switching the konomi container to true but it's still not loading the images but at least theres some level of progress. I also found out that my files were not loading in binary form so it was not executing the script properly with my current host Hostgator.

    Hopefully someone can help me get that one step further! Thanks guys! :)
     
  20. bambua

    bambua Well-Known Member

    I still believe you have a path issue somewhere, can you paste in your script, and also give us the path that the script is at and where xenforo is in relation to that?
     
    Clark likes this.

Share This Page