• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

[KL] Fonts Manager 2.0.8

No permission to download

katsulynx

Well-known member
#1
Last edited:

Solidus

Well-known member
#4
This is nice. How feasible is it to add an option for users to choose their default font? Most don't want to manually select I think.
 

katsulynx

Well-known member
#5

katsulynx

Well-known member
#8
When I click on Editor Font List or Webfont Setup the page is blank in the acp :/
If the page is completely blank (beside the normal ACP Navigation and stuff), the Admin Templates for the addon are missing, which would be weird. If there's a one-liner message shown instead, please post it here.

It is not uploading font when I choose Local Font and browse a .woff file.
Thanks for reporting, can confirm that uploading local fonts is currently not working. I'll have a look into this tomorrow.
 

Dadparvar

Well-known member
#11
Thanks.

When I write title of the fonts with "Persian" characters (UTF-8) it shows the tags and not working. (Although in editor's font list it shows correct, but it doesn't change the text in editor and the post content's style)
But when I write its title with English characters, it doesn't show tags, but again not works.

You can check this font (local font) and see the result. (for title write: نازنين)
http://up.vbiran.ir/uploads/1477514453692421948_nazanin.zip
 

BobbyWibowo

Well-known member
#13
@dvsDave Why don't you use a Defer JS add-on or something?

On a side note, works fine to add 2 Google Webfonts. Thanks! For some reason, the custom Google Webfonts used for the board wouldn't work on the editor, despite of the fact that they were loaded on the page. But after using this add-on and adding the fonts, they work. I assume it had something to do with the fact that editor was loaded in an iframe. Or dunno really.
 
Last edited:

BobbyWibowo

Well-known member
#17
On the Webfont Setup menu, whenever I tried to enter any value and pressed the Update button, that error messages would appear. Though, even after the error messages, the new value would still be added. And it didn't seem to save the Whitelist or Blacklist state.
 

katsulynx

Well-known member
#19
katsulynx updated [KL] Fonts Manager with a new update entry:

Installer Bug Fix

  • Fixed an installation bug, causing an option value to be missing and thus preventing the webfont white-/blacklist to be not fully functional.
Important: If you have already installed this addon, you will either need to fully uninstall it or execute the following command on your database:
Code:
INSERT INTO `xf_option` (`option_id`, `option_value`, `default_value`, `edit_format`, `edit_format_params`, `data_type`, `sub_options`,...
Read the rest of this update entry...
 

Dadparvar

Well-known member
#20
Thanks
I added some Persian fonts as local font. And worked.
But I don't know why this font can't be added. (I use it in my other sites. But can't add it to editor using this add-on)
When I add it, it says "Changes Saved" but when It reloads the page, its not added. and its not in editor.
I added 14 fonts and they are working fine. But I don't know why this font is not added.

Any opinion will be appreciated.
 

Attachments