1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[KL] Fonts Manager 2.0.5

Manage your available Editor Fonts

  1. katsulynx

    katsulynx Well-Known Member

    katsulynx submitted a new resource:

    [KL] Fonts Manager - Manage your avaiable Editor Fonts

    Read more about this resource...
     
    Last edited: Sep 12, 2015
    RoldanLT likes this.
  2. Bionic Rooster

    Bionic Rooster Well-Known Member

    Nice :) What fonts are included if any?
     
  3. katsulynx

    katsulynx Well-Known Member

    It doesn't come with any additional fonts. After Installation you start with the basic XenForo Font Stacks. You can upload your own fonts, choose fonts from the Google Webfont spectrum or create your own font-stacks (keeping in mind that not everyone might have them).
     
    Bionic Rooster likes this.
  4. Solidus

    Solidus Well-Known Member

    This is nice. How feasible is it to add an option for users to choose their default font? Most don't want to manually select I think.
     
    Veer likes this.
  5. katsulynx

    katsulynx Well-Known Member

    katsulynx updated [KL] Fonts Manager with a new update entry:

    New Functions & Improvements

    Read the rest of this update entry...
     
  6. iamjudd

    iamjudd Active Member

    When I click on Editor Font List or Webfont Setup the page is blank in the acp :/
     
  7. Veer

    Veer Well-Known Member

    It is not uploading font when I choose Local Font and browse a .woff file.
     
    katsulynx likes this.
  8. katsulynx

    katsulynx Well-Known Member

    If the page is completely blank (beside the normal ACP Navigation and stuff), the Admin Templates for the addon are missing, which would be weird. If there's a one-liner message shown instead, please post it here.

    Thanks for reporting, can confirm that uploading local fonts is currently not working. I'll have a look into this tomorrow.
     
  9. katsulynx

    katsulynx Well-Known Member

    katsulynx updated [KL] Fonts Manager with a new update entry:

    Bugfix

    Read the rest of this update entry...
     
  10. katsulynx

    katsulynx Well-Known Member

  11. Dadparvar

    Dadparvar Well-Known Member

    Thanks.

    When I write title of the fonts with "Persian" characters (UTF-8) it shows the tags and not working. (Although in editor's font list it shows correct, but it doesn't change the text in editor and the post content's style)
    But when I write its title with English characters, it doesn't show tags, but again not works.

    You can check this font (local font) and see the result. (for title write: نازنين)
    http://up.vbiran.ir/uploads/1477514453692421948_nazanin.zip
     
  12. dvsDave

    dvsDave Well-Known Member

    Can the javascript and the css font request be moved to the footer?
     
  13. BobbyWibowo

    BobbyWibowo Well-Known Member

    @dvsDave Why don't you use a Defer JS add-on or something?

    On a side note, works fine to add 2 Google Webfonts. Thanks! For some reason, the custom Google Webfonts used for the board wouldn't work on the editor, despite of the fact that they were loaded on the page. But after using this add-on and adding the fonts, they work. I assume it had something to do with the fact that editor was loaded in an iframe. Or dunno really.
     
    Last edited: Mar 4, 2016
  14. katsulynx

    katsulynx Well-Known Member

    That's exactly the case - and something that gave me a real headache to get it working :D
     
    BobbyWibowo likes this.
  15. BobbyWibowo

    BobbyWibowo Well-Known Member

    What's up with this?
     

    Attached Files:

  16. katsulynx

    katsulynx Well-Known Member

    That's a good question. What did you do? Is the error log showing something?
     
  17. BobbyWibowo

    BobbyWibowo Well-Known Member

    On the Webfont Setup menu, whenever I tried to enter any value and pressed the Update button, that error messages would appear. Though, even after the error messages, the new value would still be added. And it didn't seem to save the Whitelist or Blacklist state.
     
  18. katsulynx

    katsulynx Well-Known Member

    Okay, seems like I can reproduce that. I'll have a look into it.
     
  19. katsulynx

    katsulynx Well-Known Member

    katsulynx updated [KL] Fonts Manager with a new update entry:

    Installer Bug Fix

    Read the rest of this update entry...
     
  20. Dadparvar

    Dadparvar Well-Known Member

    Thanks
    I added some Persian fonts as local font. And worked.
    But I don't know why this font can't be added. (I use it in my other sites. But can't add it to editor using this add-on)
    When I add it, it says "Changes Saved" but when It reloads the page, its not added. and its not in editor.
    I added 14 fonts and they are working fine. But I don't know why this font is not added.

    Any opinion will be appreciated.
     

    Attached Files:

Share This Page