• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Keep getting logged out

Akela

Active member
#1
Some of my users keep reporting getting logged out after as long as a couple of minutes or as short as one page load after login.
I myself was able to replicate the issue on Opera and IE, but not on Firefox.
The users experiencing the issue use IE and Firefox. Those on Chrome appear to be fine (or is this just a coincidence)?
I use Cloudflare, but disabling it did not make a difference.

Having set up phpinfo file, I can tell you that _SERVER["REMOTE_ADDR"] value consistently shows my IP.
I have increased the logged in time to several hours (it used to be 60 minutes, so it shouldn't have caused a problem, anyway).
I added
Code:
$config['cache']['cacheSessions'] = true;
to the library/config.php, but it did not make any difference.

Adding
Code:
RewriteCond %{HTTP_HOST} !^datingfora\.com$ RewriteRule ^(.*)$ http://datingfora.com/$1 [R=301,L]
to my .htaccess file did not help.

Just in case, here is my entire .htaccess file:

# Mod_security can interfere with uploading of content such as attachments. If you
# cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
# SecFilterEngine Off
# SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 500 default

<IfModule mod_rewrite.c>
RewriteEngine On

# If you are having problems with the rewrite rules, remove the "#" from the
# line that begins "RewriteBase" below. You will also have to change the path
# of the rewrite to reflect the path to your XenForo installation.
RewriteBase /

# Akela
RewriteCond %{HTTP_HOST} !^datingfora\.com$
RewriteRule ^(.*)$ http://datingfora.com/$1 [R=301,L]

RewriteCond %{QUERY_STRING} (^|&)t=([0-9]+)(&|$) [NC]
RewriteRule ^viewtopic\.php$ /threads/%2? [L,R=301,NC]
RewriteCond %{QUERY_STRING} (^|&)p=([0-9]+)(&|$) [NC]
RewriteRule ^viewtopic\.php$ /posts/%2? [L,R=301,NC]
RewriteCond %{QUERY_STRING} f=(\d+)$ [NC]
RewriteRule ^viewforum\.php$ /forums/%1 [L,R=301,NC]



# end Akela

# This line may be needed to enable WebDAV editing with PHP as a CGI.
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
RewriteRule ^.*$ index.php [NC,L]
</IfModule>
I just moved from phpBB, so I have no idea whether it is something with the server or my settings. I do not have any other XF sites running on the same server. I run MyISAM tables, because my server does not support InnoDB.

What else can I try?
 

Akela

Active member
#3
Specific action? What I see on Opera is that clicking on a couple of pages logs me out. Some of my users are able to make a post or two before getting booted.

I seem to have no issues on Firefox or on my iPad, but at least one other member has reported Firefox logging them out too.
 

Akela

Active member
#4
Can the fact that I have just transferred from another domain have anything to do with this? Inconsistent URLs and all?
 

Jake Bunce

XenForo moderator
Staff member
#6
Can the fact that I have just transferred from another domain have anything to do with this? Inconsistent URLs and all?
It's possible if your users get caught during a change-over of your domain name.

Disabling Full Friendly URLs fixed the issue with Opera for me. Let's see how it works for my users.

But.. but.. I like the friendly URLs... :(
Just a guess... try uncommenting this line in your .htaccess file (and specify the name of your forum directory):

Code:
	#RewriteBase /xenforo
 

Akela

Active member
#7
Thank you for still responding, Jake :)

It's possible if your users get caught during a change-over of your domain name.
What do you mean by getting caught?

Just a guess... try uncommenting this line in your .htaccess file (and specify the name of your forum directory):
Code:
#RewriteBase /xenforo
It is already uncommented. I did that almost right after the installation...