1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Just Upgraded "successfully" but first page taken to shows erros

Discussion in 'Installation, Upgrade, and Import Support' started by phaze3131, Jul 18, 2013.

  1. phaze3131

    phaze3131 Active Member

    this is what happens right after the upgrade from 1.1.3 to 1.2, it says successful then this screen is where I end up.

    Why all the errors any ideas?

    thanks for the help
  2. Jeremy

    Jeremy Well-Known Member

    Update TMS or contact the author in the appropriate support thread for help.
    Tracy Perry likes this.
  3. Tracy Perry

    Tracy Perry Well-Known Member

    Didn't read the threads pertaining to updating and compatible add-ons huh? ;)
    TMS is NOT compatible with 1.2 yet (the RM version) so what I had to do was copy all my template edits into an editor, then I disabled all add-ons, disabled listeners in config.php and then did the update to 1.2RC1. Then I commented out the listener segment in config.php and started enabling my add-ons one by one and checking to make sure there were no problems (there were). I already knew that TMS was going to be a problem and was why I removed it before the upgrade. The edits I had in TMS were able to be done via the built in 1.2 supplied Template Modifications.
    In answer to your question - you will need to disable TMS (at the least if you can get to it) and if not, disable listeners by editing the library/config.php file and placing
    $config['enableListeners'] = 0;
    in it. After you have disabled TMS (and yes, you are going to lost the benefits of the edits that it gave - and also of the add-ons that depended upon it) then it should work.
  4. Andrej

    Andrej Well-Known Member

    Tracy Perry likes this.
  5. Tracy Perry

    Tracy Perry Well-Known Member

    Yep, that's why I said the RM version. I knew that there was a github one out. But I thought I remember someone saying that it still was not fully compatible?
    Found what I was referring to http://xenforo.com/community/threads/template-modification-system-tms.27973/page-27#post-571038.
    Looks like if you have modifications that depend on TMS, then the new github version will not work with them.
  6. phaze3131

    phaze3131 Active Member

    I uninstalled the addon and still the same problem. Maybe it is my custom theme?


    I told the developer to make sure the theme is independent of any core xenforo files so this problem does not occur....

    Do you think its my theme and can I fix it so when I upgrade these problems will not happen?

    thank you so much!
  7. Tracy Perry

    Tracy Perry Well-Known Member

  8. phaze3131

    phaze3131 Active Member

    [Edit] I did this but get this error:
    Server Error

    Mysqli statement execute error : Table 'tms_modification' already exists

    I have made a full db backup and theme backup, before I did any upgrades or anything, so that's a plus side I guess.

    I have problems all over my forum now from this upgrade, things are a legit mess.

    thanks for the help.
    Last edited: Jul 18, 2013
  9. Brandon Sheley

    Brandon Sheley Well-Known Member

    disable all your mods as mentioned above, does that help ;)
  10. phaze3131

    phaze3131 Active Member

    it does not alow me to disable them, I get this message:

    and then the check marks get placed back on and they are enabled again.

    I did what this guy said here:

    on reply #13


    I did a search for the "fields" but found none, but was able to drop the TMS table

    [edit] do you think my theme coder hard coded pieces of TMS into the theme? that would be a disaster if he did.
    Last edited: Jul 18, 2013
  11. Tracy Perry

    Tracy Perry Well-Known Member

    Have you disabled (clicked each box) for each add-on individually and made sure that NO add-ons are enabled. Then re-enable them one at a time to see if one of them is causing the problem. Several add-ons may depend on TMS and that could be related to one of them.
    If you do the disable listeners in config.php you should be able to disable them.

    EDIT: I just checked on my forum, and disabling the listeners in config.php WILL still allow you to click on the add-ons to disable them. Have you done that yet?
  12. phaze3131

    phaze3131 Active Member

    @Tracy Perry thank you alot, that allowed me to disable all of my addons, and I did them step by step, re enabling them all (besides TMS which is not installed right now)

    I do get this at the admin home

    I guess because of my custom template I am going to have big problems each time I upgrade?

    Still can't install the newer TMS, I guess I'll have to ask those guys if they can maybe help me

    thank you again
  13. Brogan

    Brogan XenForo Moderator Staff Member

    Revert the templates and re-edit them or merge them.
    Tracy Perry likes this.
  14. RoldanLT

    RoldanLT Well-Known Member

    I would suggest on this:
    - Backup all your current Template Modifications (Custom or addons TMS)
    - Un-Install TMS (Only few addons that are dependable on this / those that are outdated)
    - Disable all addons via config.php ($config['enableListeners'] = false; )
    - Upload Latest package (XF 1.2.0 / Overwrite)
    - Upgrade your Forum, best way is via CLI
    - Now enable addons one by one
    - Manually re-apply your template modifications
    - Done
  15. TBolley

    TBolley Active Member

    - Upgrade your Forum, best way is via CLI

    howto ?=
  16. RoldanLT

    RoldanLT Well-Known Member

    Connect to your server via ssh (ssh user@your_ip)
    Run this:
    php library/XenForo/Install/run-upgrade.php 
    and follow the prompts.
    Adam Howard and TBolley like this.

Share This Page