• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Is PHP 5.4 or 5.5 safe for Xenforo? What about Opcache?

MattW

Well-known member
#3
Been running 5.4 for a while now with Xcache. No issues what so ever. Works fine with 5.5 as well from my testing on my server at home.
 

p4guru

Well-known member
#8
Is it ok to run the newer versions of PHP with Xenforo?

What about using http://www.php.net/manual/en/intro.opcache.php versus using APC?

Any issues?

Anyone running these in production? Any words of wisdom?
Depends, is Xenforo only PHP using script on your server ? If not, are you 100% sure the other PHP scripts are PHP 5.4 or PHP 5.5 compatible ?

I am using on production live sites PHP 5.3.27 or PHP 5.4.18 and APC 3.1.13 + igbinary + memcached server fine with following scripts:
  • Xenforo
  • Invision Board
  • vBulletin 3.8.8, 4.2.1 and vB 5.0.4
  • Wordpress 3.5 and 3.6
Xenforo for testing I had no problems with PHP 5.5.2 at least.

I am using Nginx with PHP-FPM and find APC Cache 3.1.3+ better than Xcache for my scripts. More stable and performs better.