1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

IPB to XenForo?

Discussion in 'XenForo Pre-Sales Questions' started by gmaister22, Apr 1, 2013.

  1. gmaister22

    gmaister22 Active Member

    Hey there, i was wondering if its possible to 100% convert every content of the forum?

    It's a new forum, so it's really important for me to make it work, i dont want to break anything etc...im running the latest version (3.4.3)
  2. Fufu

    Fufu Well-Known Member

    xenForo 1.1.4 importer supports: IP.Board 3.1 & IP.Board 3.2

    I am not sure if the xenForo developers have made an official alternative solution yet.

  3. AWS

    AWS Well-Known Member

    Yes you can convert from IPB 3.4.3. Importer works very well.
  4. gmaister22

    gmaister22 Active Member

    is the procedure hard?
  5. Brogan

    Brogan XenForo Moderator Staff Member

  6. gmaister22

    gmaister22 Active Member

    Brogan you can verify that 3.4.3 works with the converters?
  7. Slavik

    Slavik XenForo Moderator Staff Member

    Yes it does
  8. Brogan

    Brogan XenForo Moderator Staff Member

    I have never used it but Bob above has confirmed it does.

    The other person who may know is Jake Bunce as he does a lot of imports.
  9. gmaister22

    gmaister22 Active Member

    Thank you :)
  10. Cambion

    Cambion Well-Known Member

  11. gmaister22

    gmaister22 Active Member

    I just purchased xenForo, i run IPB 3.4.4 but when i try to convert it there are options only for IPB 3.1 and 3.2...which one should i select?
  12. Brogan

    Brogan XenForo Moderator Staff Member

    If the schemas are similar then you can try 3.2.

    I'm not familiar with the IPB database schemas though.
  13. Teapot

    Teapot Well-Known Member

    The IPB 3.2 importer works absolutely fine for 3.3 and 3.4. :)
    gmaister22 likes this.
  14. AWS

    AWS Well-Known Member

    IPB doesn't change the db schema much until they do a major version upgrade. If they do they make sure to keep backwards compatibility for a few point releases.

Share This Page