• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Internal Server Error

DaveL

Well-known member
#1
Hi,
Ive just moved my Xenforo installation from one VPS to another.

1) Downloaded all files from VPS1
2) Uploaded all files to VPS2
3) Exported MySQL file from phpMyAdmin on VPS1
4) Imported MySQL file from phpMyAdmin on VPS2

Im now receiving this error:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator,
and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
This is my error log in cPanel

Code:
[Tue Jun 11 11:34:30 2013] [error] [client 174.237.34.151] File does not exist: /home/airportc/public_html/styles, referer: http://webcache.googleusercontent.com/search?q=cache:6vW2Aj3njp0J:www.airportcitygame.com/index.php%3Fthreads/a-city-to-remember.931/+&cd=1&hl=en&ct=clnk&gl=us
[Tue Jun 11 11:34:30 2013] [error] [client 174.237.34.151] File does not exist: /home/airportc/public_html/styles, referer: http://webcache.googleusercontent.com/search?q=cache:6vW2Aj3njp0J:www.airportcitygame.com/index.php%3Fthreads/a-city-to-remember.931/+&cd=1&hl=en&ct=clnk&gl=us
[Tue Jun 11 11:34:29 2013] [error] [client 174.237.34.151] File does not exist: /home/airportc/public_html/styles, referer: http://webcache.googleusercontent.com/search?q=cache:6vW2Aj3njp0J:www.airportcitygame.com/index.php%3Fthreads/a-city-to-remember.931/+&cd=1&hl=en&ct=clnk&gl=us
[Tue Jun 11 11:34:28 2013] [error] [client 174.237.34.151] File does not exist: /home/airportc/public_html/js/as.js, referer: http://webcache.googleusercontent.com/search?q=cache:6vW2Aj3njp0J:www.airportcitygame.com/index.php%3Fthreads/a-city-to-remember.931/+&cd=1&hl=en&ct=clnk&gl=us
[Tue Jun 11 11:33:41 2013] [error] [client 174.237.34.151] File does not exist: /home/airportc/public_html/styles, referer: http://webcache.googleusercontent.com/search?q=cache:E0UkFDuTwGcJ:www.airportcitygame.com/index.php%3Fforums/airport-city-chat.9/page-27+&cd=2&hl=en&ct=clnk&gl=us
[Tue Jun 11 11:33:41 2013] [error] [client 174.237.34.151] File does not exist: /home/airportc/public_html/styles, referer: http://webcache.googleusercontent.com/search?q=cache:E0UkFDuTwGcJ:www.airportcitygame.com/index.php%3Fforums/airport-city-chat.9/page-27+&cd=2&hl=en&ct=clnk&gl=us
[Tue Jun 11 11:33:40 2013] [error] [client 174.237.34.151] File does not exist: /home/airportc/public_html/styles, referer: http://webcache.googleusercontent.com/search?q=cache:E0UkFDuTwGcJ:www.airportcitygame.com/index.php%3Fforums/airport-city-chat.9/page-27+&cd=2&hl=en&ct=clnk&gl=us
[Tue Jun 11 11:33:40 2013] [error] [client 174.237.34.151] File does not exist: /home/airportc/public_html/styles, referer: http://webcache.googleusercontent.com/search?q=cache:E0UkFDuTwGcJ:www.airportcitygame.com/index.php%3Fforums/airport-city-chat.9/page-27+&cd=2&hl=en&ct=clnk&gl=us
[Tue Jun 11 11:33:40 2013] [error] [client 174.237.34.151] File does not exist: /home/airportc/public_html/js/as.js, referer: http://webcache.googleusercontent.com/search?q=cache:E0UkFDuTwGcJ:www.airportcitygame.com/index.php%3Fforums/airport-city-chat.9/page-27+&cd=2&hl=en&ct=clnk&gl=us
[Tue Jun 11 11:19:18 2013] [error] [client 90.208.10.9] File does not exist: /home/airportc/public_html/404.shtml, referer: http://www.airportcitygame.com/login/login?onepasswdfill=CBB446B858C21C25A493D3107EFD55C3
[Tue Jun 11 11:19:18 2013] [error] [client 90.208.10.9] File does not exist: /home/airportc/public_html/favicon.ico, referer: http://www.airportcitygame.com/login/login?onepasswdfill=CBB446B858C21C25A493D3107EFD55C3
[Tue Jun 11 11:19:18 2013] [error] [client 90.208.10.9] File does not exist: /home/airportc/public_html/404.shtml
[Tue Jun 11 11:19:18 2013] [error] [client 90.208.10.9] File does not exist: /home/airportc/public_html/login
[Tue Jun 11 11:19:11 2013] [error] [client 66.249.72.162] File does not exist: /home/airportc/public_html/404.shtml
[Tue Jun 11 11:19:11 2013] [error] [client 66.249.72.162] File does not exist: /home/airportc/public_html/threads
[Tue Jun 11 11:19:01 2013] [error] [client 91.121.154.160] File does not exist: /home/airportc/public_html/404.shtml, referer: http://www.airportcitygame.com/
[Tue Jun 11 11:19:01 2013] [error] [client 91.121.154.160] File does not exist: /home/airportc/public_html/help, referer: http://www.airportcitygame.com/
[Tue Jun 11 11:18:44 2013] [error] [client 66.249.72.206] File does not exist: /home/airportc/public_html/404.shtml
[Tue Jun 11 11:18:44 2013] [error] [client 66.249.72.206] File does not exist: /home/airportc/public_html/members
[Tue Jun 11 11:18:34 2013] [error] [client 66.249.72.206] File does not exist: /home/airportc/public_html/404.shtml
[Tue Jun 11 11:18:34 2013] [error] [client 66.249.72.206] File does not exist: /home/airportc/public_html/members
[Tue Jun 11 11:18:17 2013] [error] [client 66.249.72.206] File does not exist: /home/airportc/public_html/404.shtml
[Tue Jun 11 11:18:17 2013] [error] [client 66.249.72.206] File does not exist: /home/airportc/public_html/threads
[Tue Jun 11 11:17:57 2013] [error] [client 66.249.72.206] File does not exist: /home/airportc/public_html/404.shtml
[Tue Jun 11 11:17:57 2013] [error] [client 66.249.72.206] File does not exist: /home/airportc/public_html/members
[Tue Jun 11 11:17:52 2013] [error] [client 178.162.40.89] File does not exist: /home/airportc/public_html/404.shtml
[Tue Jun 11 11:17:52 2013] [error] [client 178.162.40.89] File does not exist: /home/airportc/public_html/styles
[Tue Jun 11 11:17:52 2013] [error] [client 178.162.40.89] File does not exist: /home/airportc/public_html/404.shtml
[Tue Jun 11 11:17:52 2013] [error] [client 178.162.40.89] File does not exist: /home/airportc/public_html/data
[Tue Jun 11 11:17:21 2013] [error] [client 66.249.72.206] File does not exist: /home/airportc/public_html/404.shtml
[Tue Jun 11 11:17:21 2013] [error] [client 66.249.72.206] File does not exist: /home/airportc/public_html/members
[Tue Jun 11 11:17:20 2013] [error] [client 66.249.72.206] File does not exist: /home/airportc/public_html/404.shtml
[Tue Jun 11 11:17:20 2013] [error] [client 66.249.72.206] File does not exist: /home/airportc/public_html/members
[Tue Jun 11 11:17:13 2013] [error] [client 87.4.136.148] File does not exist: /home/airportc/public_html/404.shtml, referer: http://www.airportcitygame.com/find-new/838847/threads
[Tue Jun 11 11:17:13 2013] [error] [client 87.4.136.148] File does not exist: /home/airportc/public_html/find-new, referer: http://www.airportcitygame.com/find-new/838847/threads
[Tue Jun 11 11:17:00 2013] [error] [client 84.105.141.29] File does not exist: /home/airportc/public_html/404.shtml
[Tue Jun 11 11:17:00 2013] [error] [client 84.105.141.29] File does not exist: /home/airportc/public_html/index.php
[Tue Jun 11 11:16:43 2013] [error] [client 66.249.72.206] File does not exist: /home/airportc/public_html/404.shtml
[Tue Jun 11 11:16:43 2013] [error] [client 66.249.72.206] File does not exist: /home/airportc/public_html/threads
[Tue Jun 11 11:16:06 2013] [error] [client 66.249.72.206] File does not exist: /home/airportc/public_html/404.shtml
[Tue Jun 11 11:16:06 2013] [error] [client 66.249.72.206] File does not exist: /home/airportc/public_html/members
[Tue Jun 11 11:15:56 2013] [error] [client 66.249.72.206] File does not exist: /home/airportc/public_html/404.shtml
[Tue Jun 11 11:15:56 2013] [error] [client 66.249.72.206] File does not exist: /home/airportc/public_html/members
[Tue Jun 11 11:15:34 2013] [error] [client 84.105.141.29] File does not exist: /home/airportc/public_html/404.shtml
 

DaveL

Well-known member
#2
Ive downloaded a Xenforo upgrade file and installed that over the top, but that did not work.

Any help really appreciated!
 

DaveL

Well-known member
#4
View the page source, do you see any additional information?
No, Nothing extra

Code:
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>500 Internal Server Error</title>
</head><body>
<h1>Internal Server Error</h1>
<p>The server encountered an internal error or
misconfiguration and was unable to complete
your request.</p>
<p>Please contact the server administrator,
dave@doverlocals.co.uk and inform them of the time the error occurred,
and anything you might have done that may have
caused the error.</p>
<p>More information about this error may be available
in the server error log.</p>
<hr>
<address>Apache/2.2.24 (Unix) mod_ssl/2.2.24 OpenSSL/1.0.0-fips mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at 46.252.192.35 Port 80</address>
</body></html>
 

Brogan

XenForo moderator
Staff member
#5
Are you able to restart the server? This is sometimes required when doing a move operation.

Also, can you access the ACP directly?
If so, it might be friendly URLs.
 

DaveL

Well-known member
#6
Are you able to restart the server? This is sometimes required when doing a move operation.

Also, can you access the ACP directly?
If so, it might be friendly URLs.
Hi Brogan. Heres what ive done so far!

Restart the sever - nil result
Unable to access ACP

I deleted my account and then used the copy from VPS1 to VPS2 option. - Still same error
Restarted server - same error

At a bit of a loss now.
 

DaveL

Well-known member
#8
Does the new server comply with the requirements.
Have you run the test script?

http://xenforo.com/xenforo-requirements-test.zip
Ive moved two other Xenforo sites over to the new VPS and they are running perfectly.

One change I did make after installing the first two sites and prior to installing my last Xenforo was I enabled Xcache. Im just currently going through the rebuilding stage after removing it. Not sure if that could be part of the problem?
 

DaveL

Well-known member
#10
Just had a look at the error log via FTP and seen this:

[11-Jun-2013 18:49:27 Europe/London] PHP Warning: PHP Startup: suhosin: Unable to initialize module
Module compiled with module API=20060613
PHP compiled with module API=20090626
These options need to match
in Unknown on line 0
[11-Jun-2013 18:20:25 UTC] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/suhosin.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/suhosin.so: cannot open shared object file: No such file or directory in Unknown on line 0
[11-Jun-2013 18:20:25 UTC] PHP Fatal error: Directive 'allow_call_time_pass_reference' is no longer available in PHP in Unknown on line 0
Is that likely to cause the issue im having?
 

DaveL

Well-known member
#12
Yeah, other two sites are running fine.

The error log from the ftp was for the site im having the issues with. Although looks like the error logs for the other two sites are full up as well.
 

Brogan

XenForo moderator
Staff member
#13
Who set up the server for you?
That module definitely needs recompiling but I don't imagine that's the cause of this particular problem if the other two sites are working.
 

DaveL

Well-known member
#14
I set the server up myself. Just going to try and reload the site again, failing that I'm going to have to redo the server from scratch and see if that makes it work.
 

SneakyDave

Well-known member
#15
Make sure your .htaccess file is copied from the old VPS and that it is correct, if you use Apache

But if you can't get into admin.php, that may not the problem,
 

SneakyDave

Well-known member
#17
Is that an error log from PHP, or is that your apache error.log? Normally those errors can be found in Apache

Do your other sites have any PHP options enabled or disabled that might make this one different?
 

DaveL

Well-known member
#18
Hi,
First error log was from the cpanel for the account. Second log I posted was located in the ftp.

All php settings for the other two forums are the same.
 

MattW

Well-known member
#19
no-debug-non-zts-20060613/suhosin.so

That suggests that PHP is looking for suhosin in 20060613 directory. If you are running php 5.4 usually has extensions installed in no-debug-non-zts-20100525
 

SneakyDave

Well-known member
#20
I'm not familiar with why an FTP log would have that info.

All the sites running the same PHP version? Can you confirm that?

Seems to be a problem with the location of yoursushoin.so file but don't know why your other sites aren't affected