1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Internal Server Error on few threads after upgrade

Discussion in 'Troubleshooting and Problems' started by DaveL, Dec 23, 2014.

  1. DaveL

    DaveL Well-Known Member


    This morning I upgraded from 1.1 to 1.4 and also changed my php from 5.2 to 5.4.

    Everything seems to be running fine, however I have two threads which throw up and Internal Server Error page.

    This is my forum - www.AirportCityGame.com

    and this is one of the threads - http://www.airportcitygame.com/index.php?threads/list-of-neighbors-with-level-9-building-items.6136/

    If you try to view any other page other then page 1, you get the error.

    Ive checked the Forum Server Log, however its showing no errors.

    Hoping someone may be able to help :)
  2. Brogan

    Brogan XenForo Moderator Staff Member

    You will need to check the server error log to see if there are any details.
  3. DaveL

    DaveL Well-Known Member

    Thanks Brogan.

    My Cpanel server log shows

    Tue Dec 23 18:13:31 2014] [error] [client 82.x.xxx43] File does not exist: /home/airportc/public_html/500.shtml, referer: http://www.airportcitygame.com/index.php?threads/server-issues.6667/page-3

    My xenforo Server error log shows noting at all.

    Ive also just gone to view a post that a modertaor has hidden. When I clicked on "Show" - It also came back with an internal sever error - again nothing in the logs.
  4. DaveL

    DaveL Well-Known Member

    Right, ive just reverted back to php 5.2 from 5.4 and all the errors vanish and everything seems to work again.

    Any issues staying on php 5.2?
  5. Andy.N

    Andy.N Well-Known Member

    It seems your server is not configured correctly. You can try to upgrade to latest PHP 5.6.4 and see if it causes any issue. I run couple of my sites on it without problem.
    DaveL likes this.
  6. Andy.N

    Andy.N Well-Known Member

    Countless security issues and lack of performance boost.
    DaveL likes this.
  7. DaveL

    DaveL Well-Known Member

    Thanks. Just took the plunge and went to 5.6 and all seems to be working well so far!
    Andy.N likes this.

Share This Page