• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Internal Server Error 500 when trying to create new account

#1
Hi!

When trying to create a new account on my site I get this error:
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
-------


The error appears for this link: www.site.com/login/login

What could be wrong?
 
#4
The support at KeyCaptcha says it doesn't work because $view->createTemplateObject doesn't work and throw error.

I don't know where to begin to look? Is there some way I could make this work?
 
#6
Sorry for my late reply, and perhaps my dumb question: Where could I see the errors? I use cpanel.

It seems to work now with KeyCaptcha after they made some changes in their code. Only problem is that the KeyCaptcha can't be shown on two places at the same time but I think it might have to do with their code.
 
#9
This is what the error log in Xenforo says: ErrorException: Argument 2 passed to XenForo_View::createTemplateObject() must be an array, string given, called in /home/biirds/public_html/library/XenForo/Captcha/KeyCaptcha.php on line 232 and defined - library/XenForo/View.php:114
 

Insy

Well-known member
#10
This is what the error log in Xenforo says: ErrorException: Argument 2 passed to XenForo_View::createTemplateObject() must be an array, string given, called in /home/biirds/public_html/library/XenForo/Captcha/KeyCaptcha.php on line 232 and defined - library/XenForo/View.php:114
The addon seems to be non-compatible with the lastest version of XenForo.