• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Intermittent 'content encoding error' on xf.com

Luke F

Well-known member
#1


Getting this on about 1-2% of page loads here on xenforo.com, has been happening for about 3-4 weeks now.

Ruled out both connection (happens behind VPN and happened before and after my recent ISP switch) and browser (happens on chrome too, didn't yet screenshot error but it's a totally different message), and happens on a couple of PCs with varying OSes.

Refreshing fixes it instantly.

I haven't had a chance to watch in wireshark to see what is actually happening at the packet level, but it renders the top bit of the page before quickly flitting to that error message.

Anyone else getting this?
 

Jake Bunce

XenForo moderator
Staff member
#3
That error usually indicates a gzip problem, and usually on the server side. But since I have never seen this reported for this site I can only assume it's an intermittent client problem, or something specific to your connection.
 

XilE

New member
#4


Getting this on about 1-2% of page loads here on xenforo.com, has been happening for about 3-4 weeks now.

Ruled out both connection (happens behind VPN and happened before and after my recent ISP switch) and browser (happens on chrome too, didn't yet screenshot error but it's a totally different message), and happens on a couple of PCs with varying OSes.

Refreshing fixes it instantly.

I haven't had a chance to watch in wireshark to see what is actually happening at the packet level, but it renders the top bit of the page before quickly flitting to that error message.

Anyone else getting this?

I've had the issue happen to me a few times but from what I've gathered there are quite a few things that can set it off.

1. Clear your browser cache, cookies, etc just to be sure.
It most likely will not fix the problem permanently or even temporarily.

2. As mentioned by Jake it could be a issue with gzip.
Open a new tab and enter the following " about:config " then you'll see a warning to be careful just confirm it.
In the search bar enter " network.http.accept-encoding "Make sure its value is " gzip, deflate " if not right click it and click the option to reset.
Some people report changing it to " true " can fix the problem but I would not recommend it since it's most likely going to cause more problems down the road.

3. Check your firewall especially if you're using Zone Alarm.
Removing all the added programs and resetting the defaults actually fixed it the first time for me.

4. Clear your ssl slate by going into your control panel then clicking internet options.
Once open click the content tab and click clear ssl slate.

5. Are you using a custom DNS? IE OpenNic if so turn it off to make sure.
If you don't know what I'm talking about ignore this.

6. Run a good privacy cleaning program like Advanced System Care or whatever you use to do that.

The last time it happened to me I did all of the following followed by a reboot.
I've not had the issue again in any browser and it's been a good while now.

Hope this helps you.
-Drew
 

imno007

Well-known member
#8
I know this is an old thread, but I've been getting the same error and thought I'd fianlly getting around to doing a search for it. My default browser is Pale Moon, which is an optimized version of FF. The page usually loads right away the second time around, so it's not a huge deal, but I'm anticipating some members asking about it when I go live with Xenforo. Will try X's suggestions...
 

imno007

Well-known member
#10
I was getting this a lot too. Strangely, it was also only happening to me on this site to begin with, but then over time, after maybe a few weeks, I started getting the error on other sites. (Talking about the encoding error, not what you caught in the image.) This is what fixed it for me:

Type "about:config" in your address bar (without the quotes, of course) and hit Enter. Then type "encoding" in the search field. Double-click "network.http.accept-encoding" and enter "true" as the string value, then click OK. Give it a shot.
 

Tracy Perry

Well-known member
#12
Type "about:config" in your address bar (without the quotes, of course) and hit Enter. Then type "encoding" in the search field. Double-click "network.http.accept-encoding" and enter "true" as the string value, then click OK. Give it a shot.
Hmmm. does not work on Chrome on a Mac. :D
You thinking Firefox huh <hint - hint, might be beneficial to advise what browser you do that on as all are different>;)?
 

imno007

Well-known member
#13
Hmmm. does not work on Chrome on a Mac. :D
You thinking Firefox huh <hint - hint, might be beneficial to advise what browser you do that on as all are different>;)?
Well, the OP never mentioned what browser he's using either, unless I missed it, but in any case as far as I know this is only an issue for FF and FF related browsers. ;)
 

Tracy Perry

Well-known member
#14
Well, the OP never mentioned what browser he's using either, unless I missed it, but in any case as far as I know this is only an issue for FF and FF related browsers. ;)
Ruled out both connection (happens behind VPN and happened before and after my recent ISP switch) and browser (happens on chrome too, didn't yet screenshot error but it's a totally different message), and happens on a couple of PCs with varying OSes.
:whistle:
Point I was trying to make is specificity helps. If the command is a FF related one then for a LOT of folks that are not as savvy it helps to reflect that info so that they aren't wasting time trying it and then googling why it doesn't work and then coming in and posting "It didn't work" posts. :D
 

imno007

Well-known member
#15
I get that. My point is that no one who's not using FF should be encountering this issue. My advice was for the OP, who I assume is using FF and would therefore be able to apply it. If he's not, then he should be more specific. Yep, I'm passing the buck. ;)

EDIT: And after all that, I just realized that someone above already gave pretty much the same advice, except he recommended not setting the string value to "true." All I can say is that's what worked for me, and I haven't had any other problems so far (knock on wood).
 
Last edited:

Tracy Perry

Well-known member
#16
I get that. My point is that no one who's not using FF should be encountering this issue. My advice was for the OP, who I assume is using FF and would therefore be able to apply it. If he's not, then he should be more specific. Yep, I'm passing the buck. ;)
He was... he stated it was happening on Chrome also - but he didn't get a screenshot of that (text was highlighted in red) and in varying OS's. You got 99 cents back!:ROFLMAO:
I know a couple of times I've gotten some real funky stuff on my Mac with Chrome when going to my 1.2B5 site (like a grid with #'s on the left border) every now and then. Can't ever replicate it though.