• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Lack of interest Installation - field 'MySQL Password' and autocomplete="off"

Romchik®

Well-known member
#1
This is not bug, but I think in install_config.php at line 41
Code:
            <input type="text" name="config[db][password]" value="" class="textCtrl" id="ctrl_config_db_password" />
should be autocomplete="off" added:
Code:
            <input type="text" autocomplete="off" name="config[db][password]"  value="" class="textCtrl" id="ctrl_config_db_password" />
 

James

Well-known member
#3
Doesn't that effectively alter a user's 'standard' internet browsing experience? A user might want to have autocomplete enabled to save typing it again, which is fair enough, we shouldn't really alter their preference.

But then again, if that input type was password, we wouldn't have this problem! It's preference really, I don't mind my browser autofilling my mySQL database password because it's not like I'm ever going to type anything similar to it for it to come up as a recommended autofill.