• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Index.html creation on v1.2

Tracy Perry

Well-known member
#1
I couldn't really think of a better place to put this (mod's if you want, please feel free to move it).
On all 3 of my forums I now have an index.html located in the root folder. That file has never been there before. On all three, it is owned by www-data (what the user nginx runs as). All three only contain hex code 00000000. All were created on 08/07 at between 21:50hrs to 23:50hrs.
I have noticed that a few other users (new mainly) have had problems with having an index.html present in their installation (probably due to their host setup - but maybe not?).
I've looked and manually ran any CRON jobs that might be the culprit but nothing appears.

What I am trying to figure out is if it is an add-on or something else. Has anyone else noticed this? I've bypassed the problem (first noticed it on my sayapple.com site as all that was displaying was a blank white page) by only allowing index.php via the forums nginx vhost setup.
 

Brogan

XenForo moderator
Staff member
#2
The 1.2 install and upgrade scripts don't have anything about creating an index.html file in the installation directory.

I have done many 1.2 clean installs and upgrades in different environments and servers and not encountered it.
 

Tracy Perry

Well-known member
#3
The 1.2 install and upgrade scripts don't have anything about creating an index.html file in the installation directory.

I have done many 1.2 clean installs and upgrades in different environments and servers and not encountered it.
Yeah, I've checked the archives and realize that there is not an index.html present. I'm wondering if it is an add-on that may be creating it or if there may be additional nginx settings that I need to set. I was curious if anyone else has had that problem - and probably not as there would be a lot more screaming for help. :p
I'm also going to check the last add-ons that I installed via the add-on installer by @Chris Deeming as I've found some files located in the root that shouldn't be there and the add-on that they are related to was installed by that utility.
 

RoldanLT

Well-known member
#4
Yeah, I've checked the archives and realize that there is not an index.html present. I'm wondering if it is an add-on that may be creating it or if there may be additional nginx settings that I need to set. I was curious if anyone else has had that problem - and probably not as there would be a lot more screaming for help. :p
I'm also going to check the last add-ons that I installed via the add-on installer by @Chris Deeming as I've found some files located in the root that shouldn't be there and the add-on that they are related to was installed by that utility.
Yes, Chris Installer addon extract zip files,xml on root directory sometimes :whistle:
 
#5
I am having a similar problem, I have xenporta installed, and I have noticed that when I post a link to my site on facebook for instance, it gives "index.html" instead of the board title. If I add /portal to my url, it will show my board title. I have added /portal to basic board information/page index route, it redirects ok, but then it does not show my board title. Not sure if it is an .htaccess issue or what is causing it. The htaccess is in root. attached is the htaccess. If anyone can help, or have any ideas, it would be appreciated.
my site is http://www.afterdarkmatter.com

Edit, I might note that upon install, I too was showing a index.html when none was present, I gave up and ended up moving my forum out of the forum folder I had it in and directly in to root. I did have a temporay index.html file in root but deleted it before installing xenforo.
 

Attachments

#7
Nope no add on installer. Not sure what is causing it. I rebooted my server thinking the server was holding it in cache.
 
Last edited:

RoyalMc

New member
#8
Update: The problem seemed to have resolved itself after about a week, so it must have been a caching issue on facebook is all I can presume.