• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Importing Problem

#1
I'm using the vBulletin 4 import from the Resource area to do a test run. So far everything has gone without a hitch. I was importing posts last night. I was past 50% for sure, but I walked away with it running. When I got back to my PC, the following error was on the screen. When I try to resume, I immediately get the same error message.

Any ideas how to correct this so the import will continue?

importerror.JPG
 

Jake Bunce

XenForo moderator
Staff member
#2
Looks like a duplicate post_id. That's strange that it would happen in the middle of the post import. I would expect this error to happen at the beginning of an import module.

To fix this error normally you would reinstall XF and start the import again, but this time don't enable the option to preserve the source ids. If you wish to preserve the source ids then you need to resolve this post_id conflict which would normally be caused by your XF forum already containing a record with xf_post.post_id = 1485738 (which shouldn't be the case for a new install of XF). Or maybe the source forum contains duplicate ids which would indicate a problem with the unique indexes on the source forum.
 

Jake Bunce

XenForo moderator
Staff member
#4
#5
Just noticed that the thread / post count numbers are not exactly the same. My first thought is that it may be from the way soft deleted posts / threads are counted.

Example
Code:
vBulletin 2003-2004 Cobra Forum =40,944 Threads 587,898 Posts
Xenforo 2003-2004 Cobra Forum  =40,943 Threads 586,517 Posts
 
 
vBulletin Turbo Forum =3,330 Threads 57,271 Posts
Xenforo Turbo Forum =3,330 Threads 57,186 Posts