1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Imported vb4 forum to xenforo but..

Discussion in 'Installation, Upgrade, and Import Support' started by Laurentius, Dec 30, 2011.

  1. Laurentius

    Laurentius Active Member

    Ok, I have now imported my vb4 forum to xenforo, When looking at the forums from the forum root everything looks ok, but When I try to access a forum I get an URL not found. I think this might be a vbseo problem, because my vb forum is in the root and the xenforo at a directory. Can someone please help me. URL: www.onlydesigned.com/forum <---- Xenforo www.onlydesigned.com <--Vb4 with vbseo.

    Also When redirecting, should I install that mod and then add the vbseo'd url redirects to the .htaccess?
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Your forum is closed so it's only accessible to administrators.

    Do you have friendly URLs enabled and is the .htacess file in place?
  3. Laurentius

    Laurentius Active Member

    I'll open them both
  4. Brogan

    Brogan XenForo Moderator Staff Member

    OK, it's a redirect issue as when the vB site is enabled, clicking on a XenForo forum takes you to the vB site.

    You will need to check your .htaccess file for any conflicts.
  5. Laurentius

    Laurentius Active Member

    Mike did that for me and solved it, I have no idea how to do what he did. I made an error, so I reinstalled the forum and now the problem is back.... Should I open another support ticket?
  6. Brogan

    Brogan XenForo Moderator Staff Member

    You can reply to the original ticket if that's the case, as I'm not sure what the original problem was or what Mike did to resolve it.
  7. Laurentius

    Laurentius Active Member

    Also when turning off vbulletin and renaming the .htacces file, nothing works either.... Then I just get page not found instead.
  8. Brogan

    Brogan XenForo Moderator Staff Member

    If you PM me the ticket number, I can check the notes to see what Mike wrote.
  9. Laurentius

    Laurentius Active Member

    The only thing I have left now is to redirect my URL's, I am ready to move my forum to the root, where my bulletin is located, can someone please explain to me how I will do this?

    Should I first delete bulletin and then move Xenforo to the root.

    Then upload the redirection made by Kier and put the Vbseo'd URL code in xenforo's .htaccess ?

    Should Some of the bulletin file still be in the root directory together with xenforo?
  10. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Moving the forum:

    1) Copy the files from /forum to /

    2) Update the URL information:

    Admin CP -> Home -> Options -> Basic Board Information

    Redirects for vBSEO URLs:

    1) Visit this URL and select your presets (from vBSEO):


    You need to copy the rewrite rules it gives you into the .htaccess file in your web root. The old vBSEO .htaccess file is no longer needed.

    2) Install Kier's redirect scripts into the web root:


    That's it.
  11. Laurentius

    Laurentius Active Member

    Thanks, but unfortunately it won't redirect anything..
  12. Laurentius

    Laurentius Active Member

    Now I have got all my threads redirected, guess it can't get better than that.. I really don't care if google must reindex all my members profiles. The most important is the threads anyway!

Share This Page