1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Image attachments do not work

Discussion in 'Troubleshooting and Problems' started by Axel B, Nov 9, 2014.

  1. Axel B

    Axel B Well-Known Member

    Hi there,

    I'm kinda new to Xenforo. Bought the software a few months ago and converted my old MyBB forum. So far very happy with the product, but today I see some odd bug with image attachments:

    For example: http://mainecoon.nl/forum/threads/nog-1-kitten-te-koop.81257/

    For some reason image attachments are not properly show. Instead of the image the BBCode is show. The strange thing is, it does show some pictures, but not all.

    I've tried to use Photobucket as a work around, but I have the same problem. See example:


    I have no clue what to do next. Any help would be highly appreciated!
  2. Brogan

    Brogan XenForo Moderator Staff Member

    As a guest I can see the thumbnails.
    Did you recently edit the post? If so, that has likely caused it to parse.

    How did you convert from MyBB?
    I suspect the problem is related to the first import step.
  3. Axel B

    Axel B Well-Known Member

    @Brogan, thanks for your fast reply!

    I converted from MyBB with the inbuild conversion tool of Xenforo. Worked like a charm. To be honest I was flabbergasted on how good and fast it was!
    The Xenforo forum is up and running for around two months now. So far no problems. Even upgraded to the latest version.

    The issues occur with some new threads. Thought it was a glitch this morning, but I see it in other topics too. I try to edit the posts and re-save them, but it does not work. Funny thing is, in the edit-mode it shows the image.

    Even more strange is that it does not happen every time. Posted the following thread this morning without a problem:

    Tried to check the issues when logged out, and also see that it shows all thumbnails. Gets more and more mysterious...

    I don't know what the procedure is, but I can give you full access if it helps. Any help is highly appreciated...
  4. Axel B

    Axel B Well-Known Member

    Gets even more mysterious. The following thread shows nicely all thumbnails and hyperlink when not logged in.


    If I check this thread when logged in the hyperlink shows as:
    [url]The Maine Coon Database[/url]
    The url is not visible and the tag of the URL is between the BBCode.
  5. Brogan

    Brogan XenForo Moderator Staff Member

    If it is showing differently when logged in or out then that could be an add-on.

    Disable all add-ons and test in a completely default unedited style with all custom JavaScript removed.
  6. Axel B

    Axel B Well-Known Member

    Will try to figure out which addon is the disturbance in the force. Thanks for your fast replies!
  7. Axel B

    Axel B Well-Known Member

    Thanks for the tip @Brogan!
    Seems TinyMCE Quattro 2.5.1 and Bb Codes & Buttons Manager 3.0.4 are the problem. Removed them. Will try to find an alternative for those two plugins ;)

    Thanks again!

Share This Page