1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not a Bug iframe not working within pages

Discussion in 'Resolved Bug Reports' started by Michael, Dec 8, 2010.

  1. Michael

    Michael Active Member

    I have been trying to use an iframe within a XF page and the header disappears when I save it, I have tried changing the URL for the iframe source and it does the same thing, the header and footer do not display leaving the breadcrumbs, the iframe and the surrounding page.

    I am logged in and when I click on the down arrow on the breadcrumbs I get this too:


    Security error occurred. Please press back, refresh the page, and try again.

    Not sure if this a bug globally or an issue of my own. Either way I would love to know how to fix this or for it to be fixed.

    Thank you.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    I've used iframes before, e.g. from Google Maps.
    <iframe width="425" height="350" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src="http://maps.google.com/maps?q=Docklands,+London&amp;ie=UTF8&amp;hq=Docklands,&amp;hnear=Westminster,+London,+United+Kingdom&amp;t=h&amp;ll=51.505149,-0.04391&amp;spn=0.016636,0.197583&amp;output=embed"></iframe><br /><small><a href="http://maps.google.com/maps?q=Docklands,+London&amp;ie=UTF8&amp;hq=Docklands,&amp;hnear=Westminster,+London,+United+Kingdom&amp;t=h&amp;ll=51.505149,-0.04391&amp;spn=0.016636,0.197583&amp;source=embed" style="color:#0000FF;text-align:left">View Larger Map</a></small>
    Can you post the code you're using?
    Michael likes this.
  3. Michael

    Michael Active Member

    It was the same as yours but without the marginheight and marginwidth, will try now and update this post with the results.

    Okay, I now have it working, I cant believe I was missing its end tag :p
  4. Brogan

    Brogan XenForo Moderator Staff Member

    No worries, glad you got it sorted :)

Share This Page