1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 I upgraded today - thought it went well, but can't like posts now

Discussion in 'Installation, Upgrade, and Import Support' started by Kierstin Payne, Dec 17, 2013.

  1. I receive the following error when I try to like a post on any forum:
    The following error occurred:

    Argument 1 passed to EWRporta_DataWriter_Discussion_Thread::_discussionPostSave() must be an array, none given, called in /home/XXX/public_html/xenforo/library/XenForo/DataWriter/Discussion.php on line 453 and defined

    1.XenForo_Application::handlePhpError() in EWRporta/DataWriter/Discussion/Thread.php at line 5

    2.EWRporta_DataWriter_Discussion_Thread->_discussionPostSave() in XenForo/DataWriter/Discussion.php at line 453

    3.XenForo_DataWriter_Discussion->_postSave() in XenForo/DataWriter.php at line 1397

    4.XenForo_DataWriter->save() in XenForo/DataWriter/DiscussionMessage/Post.php at line 103

    5.XenForo_DataWriter_DiscussionMessage_Post->_messagePostSave() in XenForo/DataWriter/DiscussionMessage.php at line 587

    6.XenForo_DataWriter_DiscussionMessage->_postSave() in XenForo/DataWriter.php at line 1397

    7.XenForo_DataWriter->save() in XenForo/LikeHandler/Post.php at line 20

    8.XenForo_LikeHandler_Post->incrementLikeCounter() in XenForo/Model/Like.php at line 236

    9.XenForo_Model_Like->likeContent() in XenForo/ControllerPublic/Post.php at line 372

    10. XenForo_ControllerPublic_Post->actionLike() in XenForo/FrontController.php at line 347

    11. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134

    XenForo_FrontController->run() in /home/XXX/public_html/xenforo/index.php at line 13
  2. Brogan

    Brogan XenForo Moderator Staff Member

    That looks to be an issue with xenporta.
    Post in the thread for it.
  3. Thanks, I figured since it was any post it was the forum and not an add on. I will look there for help. :) Thanks for pointing me in the right direction. :) (fingers crossed)
  4. Updating that add in worked! :) THANK YOU! When the add on worked after the update I figured it was fine, guess not. :)

Share This Page