• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

i think I killed me xenforo install

#1
what are the cmod permissions for "library" supposed to be?
I think I changed the permissions wrong and accidentally deleted the entire "library" folder...
site is boss-302.com
Error is:

Warning: require(/home/boss302/public_html/library/XenForo/Autoloader.php) [function.require]: failed to open stream: Permission denied in /home/boss302/public_html/index.php on line 6

Fatal error: require() [function.require]: Failed opening required '/home/boss302/public_html/library/XenForo/Autoloader.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/boss302/public_html/index.php on line 6

I do not want to do one thing until I hear back from you guys... I spent all day yesterday and today setting it up... I pray all my work was not in vane up to this point. Thanks!
I am scared to touch anything at this point.
 

MattW

Well-known member
#2
On my set up, all the folders are 755 and the files are 644 (apart from the config.php which I have set to 640).

When you say
I think I changed the permissions wrong and accidentally deleted the entire "library" folder...
have you actually deleted the library folder?
 
#3
File zilla went crazy on me and looks like it started or attempted to delete the entire "library"folder...yes..correct..
I talked to my host, they said re- upload the entire library folder and to check my permissions...
They said on that side of things (server) it appears I may have to reload all of the xenforo files again?
 

MattW

Well-known member
#4
Have you made any changes to any of the default Xenforo files? Re-uploading would be the easiest fix if it's removed that directory.
 
#5
not sure.. Being doing add ons all day...
I re uploaded the entire "library folder" and now it looks like it wants me to completely reinstall the forum, complete setup and everything... I dont want to do that... I dont want to start over.....
 

MattW

Well-known member
#6
The library folder contains the config.php file which tells the software how to connect to the DB etc.

You should be able to manually add the database details back into it (add your own settings between the ' ' s)

Code:
$config['db']['host'] = ' ';
$config['db']['port'] = ' ';
$config['db']['username'] = ' ';
$config['db']['password'] = ' ';
$config['db']['dbname'] = ' ';
 

MattW

Well-known member
#8
There should be a file called "config.php.default" in there. You can rename that to config.php and add the settings into it.
 
#11
bout to pull my hair out... there is a config.php and a Config.php on the server side...
Config.php is bigger in size than the other... I just deleted the larger as its obvious the one I edited was the smaller of the two.. here goes nothing...
 
#13
I knew this would happen...
Fatal error: Class 'Zend_Config' not found in /home/boss302/public_html/library/XenForo/Application.php on line 478

But.. I did download a home backup so that file I just popped should be in there so I can re up load it like it was....
 

MattW

Well-known member
#14
So have you done something with the Config.php file in the library/Zend folder?

Config.php in the Zend folder shouldn't have been touched.
 
#15
ok back where i was
Configuration Builder
To install XenForo, you must know how to connect to your MySQL server. If your hosting comes with cPanel or Plesk, you can find this information there.

If you are unsure what to enter here, please contact your host. These values are specific to you.

I do not see a config.php file in "library" are you sure?
 

MattW

Well-known member
#16
OK, so going back to a few posts ago.

the config.php.default file that you found, and added the details to, should be been inside the library folder. Re-name that file to config.php (lower case c) once you have added your connection details to it, and make sure it goes back into the library folder. NOT the Zend folder.

The fact there isn't a config.php file currently in the library folder is why it's trying to make you re-install the forum.
 
#18
hey your good....
Verify Configuration
Your configuration has been verified.
I am not going to tick the Remove all XenForo-related data, including posts and users