I have a peculier problem, my forum works only with PHP 7.2

Abraham54

Active member
I have a peculier problem, my forum works only with PHP 7.2

My forum, XF version 2.2.1can only work in PHP version 7.2
I have server errors when runnig a PHP version 7.3 and -7.4 - forum gives a blanc page.

[Mon Oct 19 18:23:37.986767 2020] [lsapi:error] [pid 22810:tid 140427629745920] [client 145.129.76.220:54858] [host www.piepcomp.nl] Backend fatal error: PHP Fatal error: Uncaught TypeError: Argument 1 passed to XF\\Extension::__construct() must be of the type array, bool given, called in /home/u46315p74954/domains/piepcomp.nl/public_html/src/XF/App.php on line 1554 and defined in /home/u46315p74954/domains/piepcomp.nl/public_html/src/XF/Extension.php:12\nStack trace:\n#0 /home/u46315p74954/domains/piepcomp.nl/public_html/src/XF/App.php(1554): XF\\Extension->__construct(false, false)\n#1 /home/u46315p74954/domains/piepcomp.nl/public_html/src/XF/Container.php(28): XF\\App->XF\\{closure}(Object(XF\\Container))\n#2 /home/u46315p74954/domains/piepcomp.nl/public_html/src/XF/App.php(2783): XF\\Container->offsetGet('extension')\n#3 /home/u46315p74954/domains/piepcomp.nl/public_html/src/XF/App.php(2811): XF\\App->extension()\n#4 /home/u46315p74954/domains/piepcomp.nl/public_html/src/XF/App.php(1069): XF\\App->extendClass('XF\\\\FsMounts')\n#5 /home/u46315p74954/domains/piepcomp.nl/public_html/src/XF/Container.php(28): XF\\App->XF\\{closure}(Object(XF\\Container))\n#6 /home/u46315p74954/domains/piepcomp.nl in /home/deb315p74954/domains/piepcomp.nl/public_html/src/XF/Extension.php on line 12\n, referer: https://www.piepcomp.nl/threads/hallo-allemaal-ik-ben-nieuw-hier.6316/

Also my newly installed testforum with XF 2.2.1 has the same problems!
 

Brogan

XenForo moderator
Staff member
If a new vanilla install of XF 2.2.1 doesn't work, it's definitely something server side.

It could be a problem with the PHP build(s).
 

Abraham54

Active member
This is now the newest server error with PHP 7.4:

[Mon Oct 19 19:30:41.183229 2020] [lsapi:error] [pid 19524:tid 139968202495744] [client 2a02:1810:9528:ba00:f046:d25:7cf3:e2a8:51459] [host www.piepcomp.nl] Backend fatal error: PHP Fatal error: Unknown: Failed opening required '1' (include_path='.:/opt/alt/php74/usr/share/pear') in Unknown on line 0\n, referer: https://www.piepcomp.nl/whats-new/
 

Abraham54

Active member
Aha - PHP Options:

Screenshot-2020-10-19-superserver05-zxcs-nl-Direct-Admin-v1-60-4.png
 

Abraham54

Active member
The originally used .htaccess seemed to have been damaged by setting back a back-up.
After that my site did not work in the early hours of last Sunday - I had to renew in srt the index.html file.
After that my site worked in PHP 7.2 - had I also replaced .htaccess, then my site would have worked in PHP 7.4!
 
Top