1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

i can't seem to run scripts inside the xenforo directory.

Discussion in 'Installation, Upgrade, and Import Support' started by gamesplayer, May 31, 2012.

  1. gamesplayer

    gamesplayer New Member

    i can't run php scripts inside the xenforo directory.
    in the server error log
    [Thu May 31 15:26:17 2012] [error] [client x.x.211.43] SoftException in Application.cpp:601: Directory "/home/hostname/public_html/mydomain.co.uk/xenforo" is writeable by group

    so i changed permissions 0755 on all files in that directory, but it made no difference?
     
  2. gamesplayer

    gamesplayer New Member

    it works if i rename .htaccess but then the next part of install fails
     
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    What script are you running?

    Fails with what error? The same error?
     
  4. CyclingTribe

    CyclingTribe Well-Known Member

  5. gamesplayer

    gamesplayer New Member

    thanks for the replies. yes, changing the folder permission works. also i
    changed .htaccess files as my site uses friendly urls. its installed but
    something is wrong. i need a command in htaccess to ignore all inside /forum ?
    when i try to log in today, i click a link which looks like
    http://www.example.com/forum/login/
    the pop up window appears, i enter login details
    then it goes to 404 not found. without logging me in.
    http://www.example.com/forum/login/login

    Also the these urls do not look right.
    http://www.example.com/forum/members/myname.1/

    http://www.example.com/forum/forums/main-forum.2/
     
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Normally that would mean that the .htaccess file is missing when friendly URLs are enabled. But you say that other friendly URLs are working such as http://www.example.com/forum/login , so something fishy is going on.

    Make sure there is no directory called login inside of your forum root. And try using XF's default .htaccess file (called htaccess.txt in the zip file).

    Those URLs are valid assuming an install directory of forum with friendly URLs enabled.
     
  7. gamesplayer

    gamesplayer New Member

    ok, its starting to make sense now.... another install with some name changing of directories
     
  8. gamesplayer

    gamesplayer New Member

    yes, i enabled friendly urls, but i don't like appended numbers. the .1/ .2/
    is that not removable?
     
  9. gamesplayer

    gamesplayer New Member

    looks like theres no need to reinstall after renaming
    Changed:
    RewriteBase /community/
    in .htaccess inside directory /community/
    Changed root .htaccess to
    RewriteRule ^community(/|$) - [L,NC]
    seem to work, is this the right track?
     
  10. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Also update this setting:

    Admin CP -> Home -> Options -> Basic Board Information -> Board URL

    The ids can be removed from forum URLs by setting a URL Portion:

    Admin CP -> Applications -> Display Node Tree -> [click a forum] -> URL Portion
     

Share This Page