XF 2.2 How to show group forum on a Wordpress site?

  • Thread starter Deleted member 241496
  • Start date
D

Deleted member 241496

Guest
I know integrating Wordpress and Xenforo has been discussed alot. But that is not what we are trying to do. We have a group of individuals that created a group on our site and they wish to show their forum only on their Wordpress site. We don't want to give them the database info and embedding our page isn't working. We looked at RSS as well, but it wont show the info from the group for some reason. Is there a way to display the group page only with their forum on a separate Wordpress site? If it helps, this is what we want to display on their Wordpress site:

 
Solution
Then it's a permissions issue - you likely have to be logged in or a group member to see the content.

You will need to change the permissions or contact the add-on author for assistance with changing how the RSS feed works.
D

Deleted member 241496

Guest
That seems like it wouldnt be safe to do and would open the site up to attacks? We are trying to share the RSS feed but for some reason it wont do it from the groups forum node.
 
D

Deleted member 241496

Guest
The RSS URL is https://www.talkingevs.com/forums/las-vegas-electric-vehicle-association.112/-/index.rss

However, it looks like you're using a third party add-on so there's no actual content in the feed (threads, posts).
OK, i thought we just add RSS to the end of the URL and it pulls it from there. When i check that RSS, it shows the two posts to the node for the group. The group add-on creates a thread node in xenforo which is what that RSS link is pulling. Comparing the RSS on that to the main forum RSS, it looks the same. So it should be working but isnt?

You're confusing me a bit saying there is not any actual content in the feed.
 
D

Deleted member 241496

Guest
The addon is the group add-on by @Ozzy47 . Maybe we are seeing different things, this is what is shows on my end (shows two posts to the thread, which there are):
Code:
<?xml version="1.0" encoding="utf-8"?>

<rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:slash="http://purl.org/rss/1.0/modules/slash/">

  <channel>

    <title>Las Vegas Electric Vehicle Association</title>

    <description>Las Vegas Electric Vehicle Association</description>

    <pubDate>Tue, 30 Nov 2021 19:44:36 +0000</pubDate>

    <lastBuildDate>Tue, 30 Nov 2021 19:44:36 +0000</lastBuildDate>

    <generator>Talking EVs</generator>

    <link>https://www.talkingevs.com/</link>

    <atom:link rel="self" type="application/rss+xml" href="https://www.talkingevs.com/forums/las-vegas-electric-vehicle-association.112/index.rss"/>

    <item>

      <title>General Info</title>

      <pubDate>Tue, 23 Nov 2021 04:57:28 +0000</pubDate>

      <link>https://www.talkingevs.com/threads/general-info.257/</link>

      <guid isPermaLink="false">257</guid>

      <author>invalid@example.com (LVEVA)</author>

      <category domain="https://www.talkingevs.com/forums/las-vegas-electric-vehicle-association.112/"><![CDATA[Las Vegas Electric Vehicle Association]]></category>

      <dc:creator>LVEVA</dc:creator>

      <content:encoded><![CDATA[<div class="bbWrapper">Use this thread to post general discussions about EVs and the LVEVA in general</div>]]></content:encoded>

      <slash:comments>0</slash:comments>

    </item>

    <item>

      <title>Introductions:  What are you driving?</title>

      <pubDate>Tue, 23 Nov 2021 03:09:05 +0000</pubDate>

      <link>https://www.talkingevs.com/threads/introductions-what-are-you-driving.256/</link>

      <guid isPermaLink="false">256</guid>

      <author>invalid@example.com (LVEVA)</author>

      <category domain="https://www.talkingevs.com/forums/las-vegas-electric-vehicle-association.112/"><![CDATA[Las Vegas Electric Vehicle Association]]></category>

      <dc:creator>LVEVA</dc:creator>

      <content:encoded><![CDATA[<div class="bbWrapper">Welcome to the LVEVA Forum, hosted by Talking EVs!  <br />

<br />

Let's get everyone started by introducing themselves, and telling us what EV (or EVs) you currently drive. Tell us year, make and model, and what you love about your EV.</div>]]></content:encoded>

      <slash:comments>0</slash:comments>

    </item>

  </channel>

</rss>
1638301562471.png
 

Brogan

XenForo moderator
Staff member
Then it's a permissions issue - you likely have to be logged in or a group member to see the content.

You will need to change the permissions or contact the add-on author for assistance with changing how the RSS feed works.
 
Solution
Top