1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to get Forums Twitter feed to show in XenPorta?

Discussion in 'Troubleshooting and Problems' started by BGL, Sep 26, 2012.

  1. BGL

    BGL Well-Known Member

    The Twitter box is there but it is empty.

    As I understand it from Twitter, XenPorta is doing a Search for the forum's Twitter account but if the forum's twitter account not a high traffic account, the search will not return anything so the Twitter feed box remains blank.

    One time anything showed up was when a high profile twitter account (British Airways) replied and the Twitter search that XenPorta uses picked up that comment.

    So is there a way to modify it so instead of a search of all Twitterdom, the XenPorta Twitter interface shows the forum's Twitter feed?
     
  2. MagnusB

    MagnusB Well-Known Member

    Social search is funky, basically if your twitter account isn't popular enough, you wont appear there. I just used the widget from twitter and the raw html block, seemed to be the best solution for me.
     
  3. BGL

    BGL Well-Known Member

    Not a coder. How would I do that for my forum?
     
  4. Adam Howard

    Adam Howard Well-Known Member

    Xen Porta has this built in.

    Just add your twitter user name in it. It's one of the widgets
     
  5. BGL

    BGL Well-Known Member

    I did that. The problem is unless the forums Twitter account is high profile nothing shows up in the resulting XenPorta Twitter spot. The Twitter search shell is there but there is no content. It has to do with XenPorta doing a Twitter search and Twitter notes your Twitter account won't show of it is low profile. Being and new forum and new Twitter account, it has zero Twitter search visibility.

    What I want to do get around the XenPorta/Twitter Search and use the forum's Twitter account to populate the XenPorta Twitter area.
     
  6. 0xym0r0n

    0xym0r0n Well-Known Member

    Are you talking about hashtags or actual accounts?
     
  7. jadmperry

    jadmperry Well-Known Member

    I have the same problem....mostly, the widget is empty. Sometimes, it will show something like the account name, a bunch of dead white space and three periods (...) .
     
  8. MagnusB

    MagnusB Well-Known Member

    Set up your widget at twitter.com (got to settings -> Widgets). Then set up the Raw HTML block in Xenporta, it's called RawHyperText. You need to edit the template called EWRblock_RawHyperText, remove everything, and paste in:
    HTML:
    <div class="section">
        <div class="secondaryContent">
            <!-- Your Twitter Widget Code Here -->
        </div>
    </div>
     
  9. BGL

    BGL Well-Known Member

    Great. Thanks. I'll give that a try.
     

Share This Page