XF 2.1 How to generate media previews from imported vBulletin links (without resaving)

BubbaLovesCheese

Active member
I'm not sure if I would call this a "bug" or not, but I would love to know a simple solution.

After importing my vBulletin forum to Xenforo, all the youtube and media link are just simple html links. They do not show a preview of the video/media.

I can generate the preview by editing, and resaving the post, but I was wondering if there was an automated way since I have thousands of links.

Thanks.



View attachment bandicam 2020-11-19 14-30-36-601.mp4


P.S.

This example is from my test site. I have not done the final import from vBulletin yet. So if there is something that can be done on that side before the import, then I can try that also. Thanks.
 
Last edited:

BubbaLovesCheese

Active member
Also, I'm not sure if it's related, but some of the youtube links that were imported from vBulletin are wrapped in the [URL] tag.

So it would be great if I could somehow replace all the texts with something that xenforo would recognize when importing a media link.

Maybe replace [url]https://www.youtube.com with [media]https://www.youtube.com

Or should I just strip all the [URL] and [/URL] tags from the vBulletin messages when I'm ready to import?

I can do this pre-import, or post. Whichever is easier. Thanks.

url file.JPG

P.S. The above screenshot is the Xenforo text after the import. It did not recognize youtube as media because of the url tags.
 

Attachments

  • url file.JPG
    url file.JPG
    31.2 KB · Views: 1
Last edited:
Top