1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

how to change my xF directory?

Discussion in 'XenForo Questions and Support' started by Lenin, Jan 6, 2011.

  1. Lenin

    Lenin Active Member

    I wonder if there is a way to change my xF directory ...
    is installed in the root folder, so mysite.com
    but I want to change from place to mysite.com / forum.
    there is a way?
    thanks for the help

    sorry for my bad english[​IMG]

  2. Brogan

    Brogan XenForo Moderator Staff Member

    Just move the files to the new directory and update the URL in the ACP -> Options -> Basic Board Information: Board URL

    It's that simple :)
  3. Dean

    Dean Well-Known Member

    There are copy/paste functions in cPanel File manager - Assuming you have that.. No need to use any ftp client or anything.

    Look in the directory where you unzipped the xf package to see which files should be used in the subdirectory, I assume you may have other things in your /public_html.
  4. Lenin

    Lenin Active Member

    I received this response

    I'll have to modify anything else?
    clear that I changed the permissions to 777

    Attached Files:

  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    An internal server error can be the result of incorrect permissions.

    In general, all folders should be 755 and all files should be 644. Only data and internal_data need to be 777.
  6. Lenin

    Lenin Active Member

    good already, just today I can not start session.
    mysite.com / forum / login / login
    404 Error File Not Found
  7. Lenin

    Lenin Active Member

    indeed, when trying to view a topic I get the same error ..

  8. Brogan

    Brogan XenForo Moderator Staff Member

    Do you have any redirects set up on your server/.htaccess?

    I have moved the installation directory several times without problems.
  9. Lenin

    Lenin Active Member

    I removed the file. htacces and the problem continues

  10. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    It looks like you have friendly URLs enabled in which case the .htaccess file is required. You can get the .htaccess file form the xenForo zip file. It's in the upload folder. You need to upload it to the forum directory and rename it from htaccess.txt to .htaccess
  11. Lenin

    Lenin Active Member

    thanks for the help, solved
    thanks for the help, solved ...
    htaccess also off I had was that of the problem thanks brogan.
    had not done the last of the htaccess,
    and permits had them wrong,
    thanks jake

Share This Page